Trying to run 12.6.3 from software updates

Contributor II

Just curious if anybody has seen this. I've tried this at work and on my home wifi. When I go to run the 12.6.3 update, I'll get the network error. I'll try it 2 more times and then the update just goes away, but it eventually shows back up. This is happening on a bunch of Mac's on different networks. At the time I did it, I did check and there weren't any apple server issues. We do have a couple of security tools installed that could affect it, but there are some devices that can run it. 


New Contributor II

What security tools?  Have you tried running Software Update from Safe Boot or otherwise disabling whatever those tools are?  Can the admin of those tools provide any insight?

Do you have Caching Server running anywhere on your network(s)?  If so, have you tried temporarily disabling it?

What happens if you run `sudo launchctl kickstart -k system/` and then retry Software Update, either from the GUI or command line?

Contributor II

What security tools? We use CyberArk and Netskope, but we've had devices update with them running. Haven't tried Safe Boot option. No Caching server and for the sudo command, we've ran that and that doesn't seem to do anything.

Contributor II

Seems like the error messages are different each time. All the Mac's are 6 months old 2021 M1's.





New Contributor

Hi @SMR1

I just wanted to ask if you're still encountering this issue? Because this also happens to all M1 2021 that try to update to 12.6.3. 
I hope someone can help with this issue because even if they run launchctl kickstart -k system/ the update still does not appear.


Contributor II

One of the issues was, we had our Restrictions policy set to Allow Defer updates checked, because we were trying to prevent ventura at the time. When we created a test restrictions policy with that unchecked and added some devices that were failing before and it worked better. The second part was our security application netskope. It was blocking an apple site. Not sure how it would still update on certain Mac's.