Turning off AD Homeshare in Dock Problem/Issue

jonathandykerma
New Contributor II

Our old practice was to have the "Use UNC path from Active Directory..." checkbox selected to make the home share path available in the Dock. We would like to deselect that option and instead use a script to provide a dock item to the home share.

This is working fine for Macs that stay on the LAN, but a login when OFF the LAN is still providing the home share path error during login, and dock item being added (in addition to the one that we are putting their via script).

I've tried deleting the dock.plist then 'killall Dock' and that does remove the dock item that the OS has placed, but a subsequent login will put it back, despite "Use UNC path from Active Directory..." being unchecked.

Is there something in addition I need to do in order to turn this off? I am testing on 10.12.4. The only thing that seems to have a permanent change is to delete the local mobile account. Creating the new mobile account at first login will respect the "use UNC path from Active Directory..." deselection.

Thanks, Jon.

1 ACCEPTED SOLUTION

jonathandykerma
New Contributor II

Turns out after "Use of UNC path from Active Directory" is disabled you need to run the following commands in order for the user account to refresh or in other words be aware that setting has changed.

dscl . -delete /Users/$currentUser MCXSettings
dscl . -delete /Users/$currentUser MCXFlags

View solution in original post

2 REPLIES 2

Swift
New Contributor II

jonathandykerma
New Contributor II

Turns out after "Use of UNC path from Active Directory" is disabled you need to run the following commands in order for the user account to refresh or in other words be aware that setting has changed.

dscl . -delete /Users/$currentUser MCXSettings
dscl . -delete /Users/$currentUser MCXFlags

View solution in original post