Update to MDM profile contains different server URL error

New Contributor III

We have a machine in JAMF randomly start to get this “different server URL” error. We have unenrolled and completely deleted it from JAMF. Re-enrolled, works briefly, then back to this error. Any thoughts?

I have seen others state this is a JAMF "issue" and the only way to resolve is to erase the machine and restore from backup. This is a rough and time consuming solution, curious if there's anything else we can try.




New Contributor III

Similar issue with ONE of our laptops!

checkJSSCOnnection shows correct server URL.

We tried removing profile completely (which is also odd that the user is able to remove the profiles) and then reinstall. Everything works for less than an hour and the user get prompts which says
"Allow Device Enrollment? <Company> can automatically configure your Mac based on settings provided by your System Administrator" with Cancel and Allow options.

When the user clicks Allow, it ask for password and then gets below message
"Enrolling with management server failed - Update to MDM profile contains different server URL" with OK option and Jamf stops working.

We have asked user to click Cancel on the "Allow Device Enrollment?" and things seems to be still working on day two, will see if it last longer.

New Contributor II

Same issue on one of my Macs, any solutions to this? 

macOS updates to the latest version of Ventura seemed to resolve the problem.

New Contributor

Faced with MacOS 13.0. Update to 13.3 solved it, ty!

Contributor III

macOS 13.4.1 the problem persist

This issue seemed to resolve itself for me. I also believe this error will happen if you are trying to enroll an ADE machine via enrollment link, but I am not 100% sure of that.