Updating Adobe Acrobat DC?


I'm having issues updating Adobe Acrobat DC. I downloaded the latest updater version from here ftp://ftp.adobe.com/pub/adobe/acrobat/mac/AcrobatDC/1502020042/

Created a smart group with Application Title is "Adobe Acrobat.app"
Application Version like 15
Application Version is not 15.020.20042 (latest version)

When attempting to install, i get the following error
Installing AcrobatDCUpd1502020042.pkg...
Installation failed. The installer reported: installer: Package name is Adobe Acrobat DC (15.020.20042)
installer: Upgrading at base path /
installer: The upgrade failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

The test machines have this version Adobe Acrobat.app 15.017.20053 /Applications/Adobe Acrobat DC/Adobe Acrobat.app


Contributor III

Could be a classic vs continuous track issue:

Valued Contributor

Devil is in the details, have a look at the install.log (though that's not always real telling either)

I'm seeing this on occasion, and when I look at the details of the target machine I'll find that it's already running the version of the patch being pushed. Leads me to believe that Acrobat Pro DC is auto updating, inventory update hasn't run, Casper still thinks it's the older version and tries to update.


I don't think this is a continuous vs track issue. Casper is reporting these are all Acrobat DC.

I'll take a look at the install.log. I did find 1 machine that was already up to date...but it doesn't explain the other 3 tests I had where they are running older versions. (i ran a recon on them to have them update before installing)

Valued Contributor

This might sound silly, but is the mac logged in at the time of failure? I've seen similar errors and it usually works better when not logged in.


@millersc Yes, most likely while logged in as I'm pushing at next check-in. I'll try at logout or login -- although I've never been able to get login to work. The Macs don't seem to connect to wifi fast enough to hit the trigger... only works when they're hard wired.

Valued Contributor

@bbot I agree. I use the Startup and Recurring Checkin a lot.


So I can confirmed the versioning by looking at the version number to what we have installed and found we use the "Continuous Track".

I downloaded the latest version from http://www.adobe.com/support/downloads/product.jsp?platform=Macintosh&product=1
Installed it on machines that were outdated and it installed successfully. After a few days, Casper is still reporting that it's still on the prior version.

Anyone have an idea on how to update this thing? It's driving me nuts!

Logs from Casper
Verifying DMG...
Verifying package integrity...
Installing AcrobatDCUpd1502020039.dmg...
Closing package...

Adobe Acrobat version installed on user's machine Adobe Acrobat.app 15.017.20053 /Applications/Adobe Acrobat DC/Adobe Acrobat.app

New Contributor III

I ran into this today. This is an older thread, so not sure if it's still relevant....

What I found was if the application was open, the update policy would fail. If I closed the application then re-ran the update policy, everything would update successfully.

At this point - I can come up with a few different options:

1.) Build a script with Jamf Helper messages telling the user they need to update.
2.) Install the update at Logout/login.
3.) Use the built in user notifications tab with deferment options set in order to update.

Anyone else doing anything different?