user-enrollment, jamf binary not installed

New Contributor II


I'm trying to enroll the first of a dozen new MacOS computers. I go to our user-enrollment portal and everything seems good. It installs the CA, and the MDM profile, plus a couple of other profiles (JAMF notifications & Privacy Preferences).

However, it is NOT installing the config profiles I have set up. I thought something glitched during the enrollment, so I tried to remove the framework and start over, but the jamf binary is not installed.

From the docs: "The jamf binary is installed automatically after MDM enrollment is complete."

I looked in /usr/local/bin where previously deployed computers left it, but the only thing there is something called RemoteUpdateManager. Doesn't sound like a JAMF thing, but I could be wrong. I tried the whereis and which commands and they couldn't find it.

Note, the computer shows up in the list, and I can use the "Remove MDM" Profile" command and it does remove it from the computer, so they are talking.

What could be wrong and how do I fix it?

The JSS is 10.23 & the client is 10.15.5



New Contributor

I have this problem also. Manual enrollment fails to download the jamf binary when using the If we use https:.// the jamf binary comes down in the QuickAdd package.
We suspect a proxy or firewall issue, but need to know how the client calls for the jamf binary to be installed, or whether it is pushed.
We have access to the JamfCloud server via TCP 443, which seems to be the only required port, through a transparent proxy but the binary is still failing to download and the clients are not enrolling.
Our JPS is the latest version and the client I am currently trying to enroll is 10.14.6, but it also fails on 10.15.7.

Valued Contributor II

If these are in ABM or ASM then perhaps issue sudo profiles renew -type enrollment in terminal. That will install the mdm profile and in turn the binary as well.

New Contributor