VMWare Fusion 11 Enrollment Issue

New Contributor

I have been reading discussions on here and have not been able to get this work.

I currently have a Mac Mini that is enrolled JAMF no issues. I installed VMWare Fusion 11, created a VM for Mojave. I set the Config File for the VM prior to running setting hw.model = "Macmini7,1"
serialnumber = "VM1xxxxxxxxx"

I used the same serial number as the machine just added a VM1 to the front. Proceed to install Mojave, once done check that the serial number is correct in About This Mac.

Enroll via website to enroll the machine, it downloads the Certificate and installs along with MDM profile. The machine shows up in Jamf Inventory but is set to Unmanaged. I cannot get it to ever manage. I have tried multiple machines, VMs.

If I run sudo jamf manage or anything there is no binary installed on the machine as it is a invalid command.

I am at a lost. Any help would be appreciated.


New Contributor III
New Contributor III

In addition to what you have done I also had to use hardware emulator, I used qemu.

New Contributor

The problem was fixed, the issue was I was using a serial number longer than 12 characters since I was making VMs I was adding VM1xxxxxx to the front resulting in 15 characters.

I am good now, hope this helps anyone else with fusion. All I did was add
hw.model = " "
serialNumber = " "

To the vmx file.

New Contributor II

I'm reviving this post that was opened awhile back. I am in the same boat as bpd2392. I was able to successfully enroll my first VM running Mojave, but I can't seem to get any subsequent VM's enrolled to a Managed state. I have followed the tutorial found here:

I have also heard mixed information on how to set the serial number in the vmx file. Some have stated that you generate your own random model and serial numbers while other sources have reported that you have to use an existing serial number and pair it with the correct model (which I have done several times) from ABM.

The result has been the same where the device enrolls, but defaults to unmanaged mode.

Just seeing if there are any other thoughts and ideas to try.

I'm going to respond to my own post.  What I wound up doing is creating my vm's using El Capitan as a baseline.  Then, I was able to successfully enroll my VM's in managed mode.  From there, I upgraded my VM's to the respective builds that I needed.