vpp redownload call timed out <mdmclienterror:72>



I am seeing a lot of our systems having the "vpp redownload call timed out <mdmclienterror:72>" error when cliets try to install VPP apps via Self Service on MacOS (most clients are 10.14.2).

I have tried clearing the failed commands, reconning, re-enrolling etc with no luck.

I am hesitant to revoke all apps as I have seen suggested because I am concerned about the number of people who will experience iTunes notifications about apps not being assigned (the staff at this school are fragile...).

Any advice would be appreciated.


Contributor III

@mjames @whitebeer The issue with storedownloadd crashing during MAS installs is fixed in 10.14.4 Beta 4 (18E205e). This is RADAR 47685116. Let me know if you still see problems after the update. For clarity, typical symptoms of this bug:
- Larger MAS apps like Xcode and Office fail to install and leave behind an .appdownload stub
- Needing to run multiple jamf recon commands to coerce apps to install
- MDMClientError:72 failed command seen in JSS

I've updated https://macadmins.software/mas with the latest info. The largest outstanding issue that I'm still tracking is the inability to update MAS apps through MDM when the user has the app perpetually open.

View solution in original post

407 REPLIES 407

Valued Contributor II

My Apple rep told me that he confirmed that <mdmclienterror:72> is resolved in macOS Big Sur 11.3 beta 4.

Unfortunately, I need it to work now, in Catalina because I want to leverage Self Service & VPP to upgrade Catalina Macs to Big Sur. Too little too late, Apple (assuming it's actually fixed).

Valued Contributor

how are you copying the .app



New Contributor II

There is a annoying fix for this that Jamf support gave me. Go in and delete your entry for the apps and re-create them and they work fine.

Valued Contributor

@Monkeyfist Do you mean to create another instance of the app in Computers: Mac App Store Apps?

Valued Contributor II

@Monkeyfist We tried the remove/re-add apps mumbo-jumbo. Doesn't work for us, unfortunately.


This is so frustrating. From what I understand reading this thread the "vpp redownload" issue is still not fixed and now this "Bag Load Failed". Does anyone know of a fellow admin who uses a different mdm solution. I'd just be curious if they run up against this brick wall too.

Esteemed Contributor II

@stranathan wrote:

My Apple rep told me that he confirmed that <mdmclienterror:72> is resolved in macOS Big Sur 11.3 beta 4.

I have high hopes this is true.


New Contributor III

I started seeing this immediately after renewing my expiring DEP and VPP tokens. Was working fine on Catalina 10.15.7 until then.. Now my VPP apps only install on clients with 11.2.3.