Windows 7 Enterprise and OS X Help (Bootcamp or SCCM)

New Contributor III

Hey guys!

I've been having troubles lately installing Windows 7 Enterprise via bootcamp or SCCM. During the task sequence, it reboots after installing the drivers and stays at a black screen with a blinking dash at the top left. Sometimes with the error "Non-system disk".

For the bootcamp installation, I use the drivers Bootcamp provides. Once Bootcamp is done installing the OS, it reboots and I get a black screen with the error "Non-system disk". Very rarely will I get a completed install. But when I do, I get an unresponsive keyboard and mouse basically making it useless.

This use to work for us last year, and the year before. Did Apple just stop making this work?


Partition 4 is used for Windows. We have tried letting Casper make it via a script, and we have also let bootcamp create the partition.


USB with bootcamp (Corsair, PNY, Lexar)

*Every SCCM install formats partition 4 to NTFS.

USB with 64 bit SCCM task sequence

DVD with 32 bit SCCM task secure

DVD with Windows 7 Enterprise. Manually created MS-DOS partition.

Test machine:

3 iMac (21.5-inch, Late 2013) (I tried with 10.10.4 & 10.10.5).

Bootcamp driver:


Windows 7 Enterprise with SP1 via the Volume License Service Center

I'm asking you guys here at JAMF Nation for help on this because I have no more answers!


Valued Contributor

Check your Boot Camp drivers.
Also you should install drivers in $WinPEDriver$ folder of BootCamp driver pack. Include them in your Task Sequence and test.

New Contributor III


I've included those drivers and tested them out and none of them make it go past the black screen. The one that stood out was AppleSSD.sys

I got the error:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:...

... File:Windowssystem32driversAppleSSD.sys

Status: 0xc0000428

Info:Windows cannot verify the digital signature for this file."

I disabled Windows Digital Signature Verification and it still didn't boot.

On a side note, I was able to get Windows 10 Enterprise installed very easily using bootcamp today.

New Contributor III

This might be a failed cause. Installing Windows 10 Enterprise with no issues, Windows 7 Enterprise on the other hand....