Xcode 10.2.1 update not pushing out via VPP

metalfoot77
Contributor II

I currently have a request for Xcode 10.2.1 which is the newest version (and echoed in the Mac Store Apps section of Jamf). My entire fleet has Xcode pushed to them via VPP and all machines are currently sitting at 10.1. I have Apple Software Updates policy running once a week. However, even after forcing updates, it doesn't appear to pick up the update for Xcode.

I have tried deleting Xcode off of about 20 machines and trying to trigger re-install from VPP, nothing worked. I ended up having to install manually from Self Service again just to get them back to the 10.1 level.

Also, I am running a separate policy for updating Xcode components (I found the script here) and that was run successfully on these machines as well. I just cannot get it to update to the latest version of Xcode.

Any ideas from the Jamf hive mind?

2 REPLIES 2

donmontalvo
Esteemed Contributor II

man xcode-select

Download all the versions you want from Apple's developer site, install/rename them, and let VPP keep the default path up to date.

--
https://donmontalvo.com

metalfoot77
Contributor II

Thanks for the reply. It appears that the reasoning behind why the VPP app isn't updated is that my fleet is running High Sierra. Apparently the 10.2.1 Xcode version only runs on macOS 10.14 (Mojave).