Xserve 2009 Yosemite

New Contributor III

Hey All,

We recently found a 2009 Xserve in a server room and we want to get it running with the latest version of OS X server from the app store. Here is the issue that we are running into, we get it installed but when we restart the box it will shutdown during the boot process. The progress bar only gets 1/5 of the way through then it shuts down. I tried multiple harddrives and did a minimal ram setup. No clue why it is doing this. Anyone have ideas about this?


Valued Contributor

My experience has been with the Xserve G5 - Xserve Early 2008, not the 2009 model. I found that off-the-self Hard Drives would give a wide variety of odd behavior and results. Are you using the OEM drives from Apple made for the Xserve? Apple included a custom ROM on their HD for use with Xserves.

New Contributor III

@jhalvorson We are using the OEM drives that came with it. They are small 80gb drives so we were hoping to replace them. I tired reimaging the drive multiple ways including JAMF and same behavior on all of them. What is strange is I can boot into an external drive each time without a single issue. It is just when booting in the drives apple provided.

Contributor II

@roethelbc We recently upgraded our 2009 XServe to Yosemite as well. We do have an appleRaid card in it and we've replaced the hard drives with 1 TB Enterprise HDs (I think Hitachi but not sure). I imaged it with a 10.10.2 AutoDMG image with no problems. So it is possible. Sorry that doesn't answer your question.

New Contributor III

We tried to Linux, BSD and FreeNAS our 2009, all failed. So we put VMWare ESXI on it easily and run FreeNAS, OS X 10.9 and other stuff.

Again, another non-answer to your question, but if your XSERVE has enough RAM, you could put a couple of Mac OS X on it.

Contributor III

watch the verbose startup, how far does it get before it shuts down?

Contributor III

Yea, look at verbose startup.

If that doesn't help, you could always try restoring from the OEM DVD to 10.6.8 Server then attempting an App Store upgrade to 10.10.

We still use 10.6.8 Server here with Xserve 2009 with no problems and have for many years. It's been flawless for us, but it may depend on your particular use case. We only use it for AFP, Casper, and packaged deployments-- and not for more widely used services like DNS, DHCP, etc.