Yosemite Macs cannot mount the JSS File Share

New Contributor II

We are starting to work with Macs running Yosemite and are running into issues when using policies or Casper Remote.

We currently only have a file share mount on our JSS, version 9.61, running on Windows Server 2012 R2. We have had no problems with this share being mounted on Mavericks, or earlier OS. I started testing Yosemite against the JSS. I had a policy which worked fine with Mavericks, it installed a batch of applications onto a newly configured Mac. I also created a Casper file for use with Casper Remote and made applications available via Self Service. All worked with Mavericks.

However, with Yosemite everything stalls while the file share is mounted. The relevant entries from 'ps' are:

0 15775 15319 0 5:33pm ttys002 0:00.01 sudo jamf policy 0 15776 15775 0 5:33pm ttys002 0:00.35 jamf policy 0 15823 15776 0 5:33pm ttys002 0:00.00 sh -c /usr/bin/su -l root -c "/sbin/mount_smbfs '//Domain>;<Account>:<Password>@<Server/Casper' '/Volumes/Casper'" >& '/Library/Application Support/JAMF/tmp/15776.tmp' 0 15824 15823 0 5:33pm ttys002 0:00.01 /usr/bin/su -l root -c /sbin/mount_smbfs '//Domain>;<Account>:<Password>@<Server/Casper' '/Volumes/Casper'

(I have taken out the security details.)

The temp file just has the line:

Old Password:

Now, I'm not sure which password it is waiting for as the root password hasn't been set on any of the Macs I am testing with.

Anyone else come across this problem? If so, what is the fix? I have implemented password policies and am wondering if something is falling foul of that.

Thanks in advance,

Ian Trimnell
The Open University, UK


Release Candidate Programs Tester

@idtrimnell, I guess you've resolved this by now.. But often this happens when Macs are bound to AD & so if the Casper DP. But, the users do not have permissions to read the share. (Kerberos is messing with things basically).

You can fix this by either:

  1. Granting all users Read Only to the CasperShare
  2. Move to HTTP/S for deploying packages/DMGs