"Jamf Protect needs to be updated" warning message appearing in macOS Monterey

jeffkh
New Contributor II

We're seeing this warning intermittently on computers running Monterey.

Screen Shot 2022-01-13 at 10.56.46 PM.png

 

I've verified that the computer(s) are running the latest version of the agent. I'm guessing that Jamf Protect is using Python 2.7 or earlier? (per this thread: https://developer.apple.com/forums/thread/691799)

 

Has anyone else been seeing this, and does Jamf have any input? I didn't find anything so I thought I'd ask the community before filing an actual support case.

1 REPLY 1

mainelysteve
Valued Contributor

Not seeing this here and I have at least two dozen clients on 12.0+ running Protect.

What I'm guessing is happening here is that Protect scanned a phython file and the binary was flagged as running python. The same situation happened with Big Sur when the Jamf Pro binary was flagged because folks had python scripts inside policies.