Jamf Connect Login black screen

cbrodsky
New Contributor II

I've been trying to get the trial version of Jamf Connect Login to work since Wednesday and can't seem to figure out what I'm doing wrong. I even tried following Traveling Tech Guy's blog post : https://travellingtechguy.eu/jamf-connect-login-with-azure/

But the results are the same.

Here's what's happening: Azure login window pops up asking for credentials. I put in my credentials. Next screen says create a new local password and verify with a greyed out Create Account button. Thing is - the moment I start typing the app goes black and starts over from the beginning.

Any ideas?

13 REPLIES 13

scg
New Contributor

We are also having issues with this, but it seems you are getting a bit further than us.

We log in, using AzureAD credentials, and then login window just stays blank - nothing happens.

We've also followed the Travelling Tech guy guide.

diradmin
Contributor II

Isn't Jamf Connect a Jamf supported product? Is anyone escalating to Jamf Support?

scg
New Contributor

We've got assistance with implementation planned for, but are (trying to) play with the product prior to this.

cbrodsky
New Contributor II

Good advice, submitted a support ticket with Jamf support and have been working with them for the past two days. The team is very helpful and looking into it now. My main intention for reaching out to the community was to see if anyone else was experiencing this issue and how they resolved it.

My main concern is that I think this product could solve a lot of pain points for us and that I want to get this working before the trial ends. It certainly wouldn't be easy to convince my director to purchase this product if I can't get it running.

SCG - so you never get to the screen at the top of traveling tech guy's blog post then? Have you run the debugger? Do you know when you check your azure portal for the Enterprise App if it shows that the test user successfully accessed Azure?

$ ssh user@ip $ log stream --predicate 'subsystem == "com.jamf.connect"' --debug

Are you seeing any errors?

cbrodsky
New Contributor II

So update: Jamf support escalated two times to different team members but the results were the same. At the end of which my sales support rep recommended that I buy a license as the version I was using was a beta and that the issue was resolved with a subsequent update that had not come out yet.

I received the license and tried again. The issue persists. I'm really stumped here. Hope someone knows the answer.

Edit: Upgraded to Mojave from High Sierra and the issue resolved. Reached out to Support to let them know about this and received back a message explaining that they found a bug in the current roll out that was causing 10.12 and 10.13 to fail but it works on 10.14.

fskelton
New Contributor

I had exactly the same issue on High Sierra with the trial version.
Also worked fine when I upgraded to Mojave.

chase_g
New Contributor III

@scg did you ever figure out the problem with getting a blank screen? I am running into the exact same issue. I get Azure login screen to come up, enter username, then password, and then screen goes blank and nothing happens.

josh_wisenbaker
New Contributor III

This issue will be fixed in the next version of Jamf Connect Login very soon.

dvaldez
New Contributor

@josh.wisenbaker is there an ETA this is a show stopper when logging in and getting a blank screen or an infinite loop of having to add credentials

BarNe
New Contributor

@dvaldez how did you get over on the infinite loop of login to azure issue?

jlombardo
New Contributor III

I am also stuck on this issue... Sign in loop where you sign in, screen goes black, and then it asks to sign in via O365 login again. I am using Mojave 10.14.6

I am currently on the trial version also.

Anyone find a solution?

Y_devgan
New Contributor III

I got this error on Jamf Connect 2.0. Testing it on macOS 10.15

snoble
New Contributor

Same issue here - Jamf Connect 2.0.2 with Catalina 10.15.7