Password Syncing issue

Contributor III


When users change their Azure AD password outside of Jamf Connect and then want to log in to a workstation with Jamf Connect and type their new password, they get the message "Password no valid".

When they type their old password, they are logged in, but they are not prompted to update the local password at this time.
We may have waited several hours but no message inviting us to update the local password.

So if they log out and log back in, they still get the "Invalid Password" message when they type their updated Azure AD password in the window.

Is this normal? Is it a bad setting of our configuration profiles?
in Jamf Connect Settings profiles, we have "NetworkCheck" key set to 15.

We are in version 2.7.0.

Thank you for your help


New Contributor

I am getting the same error and can't seem to figure out what's going on. Have you made any headway on this? 

Appreciate the help.


Hello @L0GANB,

We fixed this issue by updating Jamf Connect to 2.13

New Contributor

Hello @glpi-ios 

Thanks for your help with this. Did the upgrade and issue is resolved.