newbie question

New Contributor

I am trying to lock down the ability to have 'private wi-fi address'.  I went to the enrollment link and successfully enrolled the tablet. However i can still toggle the private wi-fi address option on the tablet.   

Am i missing a step?


wifi package.jpgwifi package 2.png

 enrollment 2.gif

enrollment 3.gif



I've noticed that some settings can still be toggled off and on even if they are enforced, but will not actually change the setting. If you turn "private wi-fi address" off, close the settings app and reopen it, does it then show it in the on position?

thanks for the suggestion jay, unfortunetly  yes the setting persists even after closing setting then opening back up.  I am using an iPad with OS 16.

Valued Contributor

hi kathikeyan, that was an interesting read, but do you happen to have a step by step guide to getting this to work? Im a newbie so that thread did not leave me understanding how to get this to work.

Try unscoping the profile from the device then once you have confirmed that it's been removed, reapply it to see if it's then enforced. Also bear in mind that the MAC Address Randomization setting only applies to a single SSID, so you'll need to add a separate payload for each SSID that you want to disable "MAC Address Randomization" for.

I removed the device management, then reapplied it, and this time I noticed the below screenshot where it says Private Wifi is turned off by your network provider.   However, the strange thing is, I can still toggle the private wi-fi address option, and when i do that, that message disappears, even though the device is still enrolled/managed.


Any ideas what would cause this? 


pic after aply 2.jpg

The fact that you can see the privacy warning would indicate that the setting has applied. I just tested it on iOS 16 and the toggle is greyed out. What version of iOS are you running? Can you share a screenshot of your configuration profile to see if there's anything obvious there?

iOS 16.1.1.   Regarding the configuration profile, where do I see that? its not the enroll.mobileconfig file is it?  Because that looks to be compiled.



Under Devices, go to Configuration Profiles and you should have a config profile with the Wi-Fi payload. Or have you configured it using something else and then uploaded a .mobileconfig file? If so, I would recommend trying to configure it in Jamf Pro directly, to eliminate any third party issue and see if that fixes your problem.