iPad not checking in

New Contributor

I've got an iPad that just refuses to check in. I've confirmed it's connected to Wifi and unlocked. I've also checked the APN in JAMF and Apple. Any suggestions?


Contributor II

re-enroll or if DEP enrolled I would probably just reset the device. 

Valued Contributor

Check to see if the MDM Profile Expiration Date has passed. You can see this in Jamf by going to the device in question > General > Scroll down to about midway for MDM Profile Expiration Date. Another way to check is on the device itself, go to Settings > General > VPN and Device Managment > Select Management Profile > More Details > Scroll down until you see Device Identity Certificate and check the date on this.


I've recently had a call open with Jamf because 100+ devices have had their MDM Profile Expire even though they're meant to renew 180 days before expiry. They haven't given me and explanation why and just said maybe we cancelled the renew command. Still waiting to hear back from them. They asked me to re-enrol all the devices that this has happened to.

The date is fine there. it's not due to expire until 9th December. Re-enrolling is a massive pain

Valued Contributor

Yep it's a pain. We sometimes get devices that get all setup and enrol correctly but stop checking in the next day. This can be a real pain at the beginning of a school year when you're enrolling 100s of devices and don't find out until later on that some devices stop checking in. It's usually straight after setup as if there's a blip somewhere to disrupt it.

I am experiencing this on some of my ipads. About 12-15 so far (out of ~2500). Nothing I do other than a full erase can seem to bring them back, very frustrating. 

I checked all certificates, none expired. I was able to get a single command to go through once, then it stopped. Won't update inventory, etc.. it's like the iPad just stops checking in. 

Contributor II

This started happening to rare devices for us about the same time as your post. We were all up to date at that point (15.4 something I believe). Nothing had changed on our end, no new configs etc.

Now I get these rare (about 15 maybe so far out of 2500) iPads that seem to just be stuck / not checking in. They have internet, I've even tried ethernet (which I use to unlock passcodes on student devices when they try too many times). I've even gone as far as removing the enrollment all together and then manually reenrolling the device. (on the ones that would let me). The latest one in front of me is at the point it won't do anything, i cant even get it to accept a restart or unmanage). 

it is very annoying, having to ask students to back up things like Sketchbook that you have to export ONE file at a time *sigh*. 

This just started occurring for us, I've gotten two out of 4000 devices so far that just refuse to check in or download apps.   What I find odd is they'll request an app from self-service just fine, I see the request come up in JAMF, but it just sits there pending just like every other request.   tried on internal and external networks just in case it was us.  nope.    

I did note on the second one, inventory update started at 6:43 AM on a school day at an external IP address, and last completed command was at 7:58AM, school starts at 8:10AM, student lives 10 min away...   I wonder if something about having the network connection interrupted is the issue.    In the past I've seen single apps get stuck when the connection is interrupted requiring a delete and re-install, no biggie.   but if an interruption causes an iPad to stop communicating completely, that's a definite issue. 


This is an iPad 8 on iOS 15.6.1   other then the lack of MDM connectivity, the iPad is acting fine. It stopped communicating two weeks ago, I'm only hearing about it now because the student is missing an app for a class and it won't download from self service.   (this also makes me fear there are far more than just the two out there in use right now) 

Contributor II

We are also noticing this.  Have been monitoring a smart group that show iPads that have not checked into inventory for 10 days.  Seeing a few populate the group each week.  Seems to somehow be related to an app update that "gets stuck".  The only solution I have found is to wipe the iPad and reset. 

I have been able to get some to check back in by cancelling everything that is pending, doing an MDM Renew, reboot the ipad. Give it a few minutes after screen unlock and it will check back in and start downloading some stuff. it will get stuck again, reboot - wait. Rinse and repeat until everything is updated. 


After dealing with this countless times this year it appears to be related to a stuck app update for sure. I am wondering if its a full iPad that stops the update, then even after space is made the app is still stuck. 

Quicker to just wipe the iPad when possible. I had a student who was adamant to not lose things and was worried about getting it all backed up so I stuck with it and after about an hour of this game it was fully up to date (app wise) and checking back in normally. 

Contributor II

Had a similar experience. Did a hard restart and it checked in and some apps updated.  But then a bunch just stuck loading and it would not update inventory again after that.