Issue enrolling iPhone via Apple Configurator 2.13.3

New Contributor


I am having some major issues with Enrolling an iPhone 6S using Apple Configurator.

I manage 2 Jamf Now accounts, one for my business and another for a client, and to be honest, enrolment has never been easy, pretty much every time there is some problem. The thing is, normally after a bit of Googling and looking through old threads on the forum, I'm able to get it done. This time around, I've tried everything I can think off and still can't get it to work.

I am using a Jamf Now account, Apple Business Manager, APNs and Auto-Enrolment are set up and validated. The iPhone is on iOS 14.4.1 and I have tried running Apple Configurator through my MacBook Pro and today as another attempt I have tried running it through my Hackintosh running 10.15.6

I have tried doing the enrolment with a WiFi profile, setting up WiFi manually, 4G connection, Mobile hotspot, and still 99% of the time I get the: Provisional Enrolment failed message

There was one time a few weeks ago, that I don't remember exactly what configuration I had, but I managed to get successfully complete the process through Apple Configurator, however when trying to set up the iPhone it says that it cannot download the Profile and that it is invalid.

I have Reset the phone a few times, and on my last attempt (today) I started completely from scratch on my Hackintosh following directions to the letter from this video:
Still no luck!

Please note I have successfully been able to enrol a few iPhones to this Jamf Now account in fact there are a few active devices there, but I'm not having any luck this time around! Please help! This is frustrating me to the point I want to run over the phone with my car!

I look forward to your responses and thank you in advance!