10.8.2 NBI on 10.7 Server Problem

New Contributor

So we just recently just got Apple's newest 13" Retina MBP so I went to create an NBI from it using it's system image utility and Casper Automator Action. Everything seemed to compile fine but after importing into Server Admin on the 10.7 server box and advertising it out client machines cannot boot to it. It shows up in the start up disks and attempts to boot to it but eventually just boots to to the internal HD. Has anyone had a similar issue using JSS 8.62?? Thanks in advance!




We've had this issue since Lion and internet recovery. Seems the firmware doesn't allow netbooting when the DHCP server is on a different subnet. We were hoping that newer macs are unaffected but doesn't sound like that's the case.

Release Candidate Programs Tester

The fix for this issue is to add helper IPs to your switches. People have tried a number of other fixes, but helper IPs seem to be the only solution that really works.

Background info on helper IPs:



Valued Contributor

FWIW, I am netbooting 10.6,10.7,10.8,10.8.2 on a 10.4.11 server, 10.6 Server and 10.8.2 server. I ran into the same issue when the new mac minis came in. The new NBI would only work on NEW Hardware.Apple is messing with the hardware again, there are a few discussions on the board


Contributor II

I concur with rtrouton on this, Helper IPs are really the best solution.

If you must go the manual route though with (stolen from http://derflounder.wordpress.com/2011/12/08/netbooting-across-subnets/)

sudo bless --netboot --booter tftp://ip.address.here/NetBoot/NetBootSP0/NetBoot-Set-Name-Here.nbi/i386/booter --kernel tftp://ip.address.here/NetBoot/NetBootSP0/NetBoot-Set-Name-Here.nbi/i386/mach.macosx --kernelcache tftp://ip.address.here/NetBoot/NetBootSP0/NetBoot-Set-Name-Here.nbi/i386/x86_64/kernelcache --options "rp=nfs:ip.address.here:/private/tftpboot/NetBoot/NetBootSP0:NetBoot-Set-Name-Here.nbi/NetInstall.sparseimage"

Make sure there are no spaces inside of your netboot set names / sparseimage / dog / filestructure of where you store netboot images


More info:

I worked with Apple on the new behavior and they say its working as designed according to the BSDP spec. I've put in an RFE for them to change it a bit so we can do bless to a specific IP address and it will work without the IP helper.

But until then... add the IP helper to the routers would be the best thing to do.