2019-Feb - Computer Prestage Error "Unable to contact https://mdmenrollment.apple.com"

New Contributor III

In my my web hosted JSS I am getting an error in one of the PreStage enrollment groups:

"Unable to contact https://mdmenrollment.apple.com to remove a device from a PreStage enrollment"

I see discussions from years ago but am wondering if this is an ongoing unresolved issue with Jamf or is there a fix to the problem.

Computers 1118
Mobile Devices 1123



Valued Contributor II

This happens on occasion to us. A workaround for us was re associating our Apple School/Business Manager account with a new Jamf / MDM server token

Looking for a Jamf Managed Service Provider? Look no further than Rocketman

Virtual MacAdmins Monthly Meetup - First Friday, Every Month

New Contributor III

Thanks Hugonaut,

I will try this however downloading a new server token seems to be the catch-all fix for many communication problems with Jamf.
We do this about 4 or 5 times a year (on the instruction of tech support) every time something goes wrong. I don't understand why the token would be bad when it is supposed to last a year.

Contributor II

Go to Device Enrollment Program in Settings. Click the Refresh button. Does the error go away?
I fought this for months on two different servers. After many requests to the network security team, the error finally went away on our Production server. After security opened communication to our Development server, that error returned to the Production server. The refresh button worked every time. Of course, it returns later.
I recommend you check to see if any changes were made to your network prior to this error.

New Contributor III

I too have suffered with this issue, but making sure that none of my prestages have more than 5,000 devices has fixed the issue.

New Contributor III

Thanks Guys,

I uploaded a new token - Still have the error.

When I push the refresh button in "Device Enrollment Program in Settings", the error goes away but comes back when I click done.

Thanks ndeangelis, not a problem with our groups (no more than 5000). About 850 computers in that group.

Contributor II

Sounds like a network/firewall/proxy problem. That is what I have been fighting network security about for months.

Contributor II

Roughly the same error but with a different issue. - Turned out our JSS server time was off by a few minutes.

Contributor III

We are seeing this same issue. I have uploaded a new token, checked time, rebooted the JSS server, all with no effect. Everything was working fine until two days ago when this message popped up. I checked the MDM server status in Apple School Manager, and at least it is now showing our server as having last communicated recently. But were still seeing this error in the JSS web page. Maybe it is just taking a little time to finish updating.