Add macOS Sierra to Casper?

New Contributor II

Hi all,

I'm trying to get my hands on a copy of macOS Sierra from our developers. I was just wondering what format the OS is in this year? Do they provide you with the full OS, or just a package file that directs you to the App Store to download it?

Ideally, I'd like to be able to add the OS into one of our builds, and allow the support engineers to trial it.


New Contributor III

Hi Lewis,

Currently you will need a developers account. You can obtain one here -

The developer link provided on the downloads page will give your Apple ID a code to redeem so that you can install via the App Store.

New Contributor II

Thanks for the response @ShadowGT, one of the developers at my company will hopefully add me to our account so I can obtain it.

Will I be able to add the OS into JSS, when I get a dev account? I am currently on the OS X Dev Beta, however it never let me download the full OS, only an incremental update.

New Contributor III

@lewis.lebentz you can try to add this beta OS to the JSS. But it may or may not work. You may want to wait for a proper version of the JSS that has support, on a test JSS instance or spin up one of the JSS Beta environment that may have support for this new platform.

The DMG is actually inside the the OS Installer Application package. Right click and show package contents:
ContentsShared SupportInstallESD.dmg

Honored Contributor II
Honored Contributor II

It might give you a bit of an early indication but you will probably get so many errors with apps, printing and other systems that I'd probably wait a few months.

As @ShadowGT mentioned, Casper may not work with it yet either.

Contributor III

So for a quick test I did a fresh build of Sierra to test out. Created local admin account log in with and then used our enrollment page to get the enrollment package. Ran the package and it enrolled in Casper fine. Casper shows it as 10.12. I then started the overlay image on it and really have only run into issues with the network part. We use a network proxy for http, https, and ftp - and it had issues communicating to Casper with it turned on. So I turned that part off for now and everything else is actually working.

Will run further tests with Casper once it's finished. But so far, there is plenty to test.

Valued Contributor

At least there doesn't seem to be any surprise complications like SIP this year. That should make updates easier.

It'll be more interesting to see how APFS (Apple File System) is handled. Will the update to Sierra migrate the disk format? Will it require a reimage? It doesn't seem to be required (yet) for Sierra. But all of this is in flux as both Sierra and APFS are in dev releases - nothing is final. :)

Honored Contributor

APFS is there but not used yet. Many limitations on it at this point such as no boot drive, case-sensitive, etc.
Looks like maybe some good bits from ZFS are there...but can only use on an external source for now.
Probably shouldn't really talk about it here. All that I found online so far.

Contributor III

@cwaldrip So I can answer some of those questions. So I had one machine I upgraded from it's already built state and it stayed at OS X Extended. So unless you wipe the disk and re-format it using a recovery partition with Sierra on it - it stays what it currently is.

So for those of you who have access to it, I found a great little article on how to create a VM for Fusion to use for testing. I'll post the directions here since I don't think we want to start too many threads about Sierra just yet:

For those wondering if you can install macOS Sierra as a VM in Fusion, the answer is: Yes you can!

<rant> It does require a bit of a workaround however. VMware Fusion uses their own custom script to create a temporary VMDK which the VM boots off. They've been using this since Mavericks and quite frankly, it's time to drop their own custom nonsense as Apple has been providing 'createinstallmedia' for a few years now. </rant>

What you'll need:

    Latest greatest macOS Sierra installer (obviously)
    VMware Fusion 8.1.1 (only tested on this version)
    Bit of CLI skills
    Freshly created VM (I just created a custom vm with stock standard settings choosing OS X 10.11 as the type)

Part 1: Creating the installer disk image.

Fire up Disk Utility and create a blank sparse disk image or use 'hdiutil', whichever you like. Size: 6GB.

    hdiutil create -size 6GB -fs JHFS+ -volname "macOS_installmedia" -type SPARSE ~/Desktop/macOS_installmedia  

Mount it (or double-click in Finder to mount):

    hdiutil mount ~/Desktop/macOS_installmedia.sparseimage  

Next use ‘createinstallmedia' from the macOS Installer:

    sudo /Applications/Install 10.12 Developer --volume /Volumes/macOS_installmedia --applicationpath /Applications/Install 10.12 Developer  

Part 2: Make the vmdk

The newly created install media should still be mounted, if not just mount the macOS_installmedia.sparseimage again.

Before we start, you need the device id of the mounted sparse disk, so run ‘diskutil list’. Look for the volume “Install 10.12 Developer Preview” and note the device id for that disk, in my environment this was: ‘/dev/disk2’

Next we need to create a vmdk, for this we use ‘vmware-rawdiskCreator’. Specify the path so that the resulting vmdk is created inside your freshly created VM’s folder (just simplifies the next step).

    /Applications/VMware create /dev/disk2 2 ~/Documents/Virtual Machines.localized/macOS.vmwarevm/macOS_installmedia lsilogic  

What we have now, is a vmdk pointer that refers to our mounted sparsedisk (thus, don’t try and unmount the sparsedisk).

Part 3: Attach vmdk to your VM

Unfortunately you can’t attach an existing vmdk that happens to be a rawDisk, so we need to edit the vmx file for our VM.

Navigate to it, in my case that would be ~/Documents/Virtual Machines.localized/macOS.vmwarevm

Use your favourite editor, such as vi or nano, then add these lines (added mine right below the first set of sata0xxx lines to macOS.vmx (or whatever you happen to call your VM):

    sata0:2.present = "TRUE"  
    sata0:2.fileName = "macOS_installmedia.vmdk"  
    sata0:2.deviceType = "rawDisk"  
    suspend.disabled = "TRUE"  

Save the vmx file

Part 4: Power On

Ignition, launch! All should be working at this point and your VM should be booting up just fine, unless either one of us messed up somewhere along the line.

Once the install has run through, you can power it off and remove the lines you added in the vmx file in Part 3.

I'm testing it's working but a little slow.

Honored Contributor

APFS is getting a spotlight shined on it (which is great) but I want to make sure you are aware of what the magician is distracting you from as well... According to release notes the very last line says "The HFS Standard filesystem is no longer supported"

I hear you saying, "We haven't used HFS in 15 years!" Neither have I, but I know a LOT of small businesses and EDU users who still rely on Zip disks for backups and archives. Since those discs came in 100MB and 250MB varieties, it was unlikely that they would have been formatted HFS+. If you have users with older storage media under 2 GB in size, you may want to do some spot checks to see how they are formatted.

Contributor III

@AVmcclint Good catch! Will have to check our machines to see if any would be effected by this.

Does anyone know if APFS is needed for storage optimization? While I won't be able to use it at work (security frowns upon icloud) I think it would be cool to use at home. I have a SSD hard drive for my main drive and it's only 128 gigs and seems to be running low a lot.

So just read this on the release notes:

Apple File System (APFS)
You can use the command-line tool 'diskutil' in macOS 10.12 to create an Apple File System (APFS) container on an external hard drive, partition or disk image. APFS volumes in macOS 10.12 are case sensitive, cannot be shared over the network via AFP, do not support Time Machine backups, and cannot be used in conjunction with a Fusion Drive or as a startup volume.```

What caught my attention was the inability to share over AFP. I use AFP for pretty much most of my shares.

Valued Contributor

I'd be scared if there was any important data still being stored on Zip disks. If there is, then the users should seriously consider verifying their data and evaluate moving it to newer media as an annual policy (if not more frequently).

Personally, over the years, I've copied old data to newer media, while still keeping the last, older, media. I've got files that started life on 5.25", was copied to 3.5", then to Syquest, and Zip, maybe even some Sony SuperDisks, to CD, then DVD, and finally in the cloud. None of that media is guaranteed to last forever. And each step of the way I've weighed how important the files were.

You have to plan for future obsolesce, otherwise just burn your backups now. :-

Honored Contributor

One thing to note too - you won't be able to access drives in APFS with OS's lower than 10.12.
The transition will need to be a careful one, which is why I'm sure it's not being used at this point.
Lots to work out before it's viable.

As for data on old HFS volumes, yeah, I'd be worried like @cwaldrip stated. We had some archives on DVD-R and CD-R that were pulled out of the drawers a couple years back. All of them from the 90's, all of them not anywhere else. I'd wager that about 40% of those disks failed. It was GB's of valuable assets that are now gone.
You won't want that and I'd look at doing something sooner than later about that!

Contributor II

The thing about Time Machine backups will have to be fixed by the time 10.12 goes live, won't it?

Valued Contributor

@znilsson Oh, oh yeah. All the current limitations are just that - current limitations. With regard to TimeMachine, the documentation for AFPS talks about some really cool features with regards to backups and expanding drive space and more. I think the current TimeMachine limitation is due to TimeMachine not knowing what to do with AFPS and TimeMachine missing lots of potential features that Apple will include.

New Contributor III

For Vmware Fusion 8, Another way that I find easier is to compile the MacOS Sierra in AutoDMG, then upload that image file to Casper Admin. Create a new VM, have it netboot into your environment, using Casper Image or Disk Utility depending on how you want to image and access your DP. Images just fine with Casper 9.92. Then just install the Vmware Tools once your done and set!

New Contributor III

@drheiner What version of AutoDMG are you using that works with macOS Sierra? I've had no success with v1.5.5 (but haven't tried again in the last 10 days or so).

New Contributor III

@jkeller13 This is how I did it, First, make sure you are on a vanilla build of MacOS Sierra (DP1). Download AutoDMG 1.5.5 with the latest profiles. Take the Mac Sierra Installer (DP1) and place into AutoDMG. It should see it, and allow you to compile it (Do not add any other files into it or allow any updates).

Valued Contributor II

Has anyone tried to install the Beta Sierra via Self Service with success?

using two poicies 1 = Cache (caching the installer works) 2 - install cached ?

when running the self service policy (install cached) i get the following error

Verifying package integrity...
Installing Test-Install macOS Sierra Public Beta.InstallESD.dmg...
Preparing for in-place OS upgrade...
Unable to find brtool. Unable to find brtool in /Volumes/OS X Base System: (null)
Closing package...