Apple TV 4th Gen and Enterprise Wireless

New Contributor II

I'm just about to start rolling out Generation 4 Apple TV's to all my classroom, but have come across an interesting problem.

All devices are enrolled into DEP and JAMF Pro (although i'm pretty sure that its an Apple Issue, not a JAMF issue)

Brand new Apple TV's get set up and profiles get pushed from JAMF and the Apple TV connects to our Wireless Enterprise Network. Within a few hours or after hard restart the device we find we can no longer connect to our wireless network. If i connect an ethernet cable to the device wait 5-10 seconds an disconnect the cable, it will then again connect to wireless until the system goes to sleep or gets powered off.

I've seen this issue before on early apple tvs where they would not keep the correct time after a hard reset. This fault was eventually fixed with an update and since then all our Gen 3's have worked perfectly.

Like I said, i'm pretty sure its not an JAMF issue, but was hoping someone else has had the same fault and any possible work around.



Valued Contributor III

I'm seeing good wireless behavior on the 4K Apple TVs but seeing crummy behavior on the Ethernet line. So crummy I have filed with AppleCare Enterprise. Our network admins constantly see the devices going up/down/up/down/up/down...etc.

The users seem to see zero negative impact but my network team isn't happy. I have escalated to AppleCare Enterprise and they guy was able to reproduce in his lab and I have the following AppleCare discussion post where other admins are having it:

I contributed my logs to this posting if it helps. would love to hear anyone else's experiences on Apple TV 4K


Hey, I'm Not sure if this is the same problem your having, but when I first deployed Apple TVs in my environment, they would come out of configurator/dep with wifi working profiles that I had preselected. I noticed at next checkin they would lose internet access because they were falling under a scope to deploy a WiFi profile that did not support the Apple TVs. (similar network profile created for the iOS devices). My problem ended up being the network profile that I scoped to them was not supported by the Apple TVs. In my JSS currently, I have a separate configuration profile for Apple TVs. The first profile is scoped to my iPads, the second is scoped to my apple tvs. I'm not sure if this is different in version 10. 3442af3abc6742d9b9b0cfeeb2d25bba

New Contributor III

We currently have around 60 Apple TVs setup with a WPA 2 configuration profile key within JAMF Pro, we have seen similar results with the wifi disconnecting after the device sleeps/restarts. I have then just joined our Guest network and it has worked fine. We have also noticed some extreme slowdown when mirroring from 2016 Macbook Pros, especially with video playback. I am currently still working to find a solution.

Valued Contributor III

What’s really weird is that my issues seem isolated to the 4K model only and occur even fresh out of the box with zero MDM config. The same issue does NOT occur on a 3rd gen model. I don’t have the 4th gen model without 4K but from what I’ve read it does not have the issue either.

New Contributor

Have you tried connecting the 4th Gen Apple TV's to ethernet? I wonder if the 4th Gen Apple TV's would stay awake then.

I recently attended a conference where Apple was presenting. The Apple System Engineer recommended the 4th Gen Apple TV's should be connected via Ethernet on the same VLAN as the teacher device. When the TV is set up in this way the Apple TV will be able to communicate in an ad-hoc (peer-to-peer) network with the teacher device on the 5ghz channels 149, 153, 157, 161. ( Ideally, you should configure the Wi-Fi AP's to not use those channels so the Apple TV & P2P devices have an open channel. )

Once the teacher device airplay's to the TV, then something new happens on the 4th gen Apple TVs. In previous versions of Apple TV, the user device & the Apple TV would communicate everything via Bonjour over wireless. When the user wanted to stream a youtube video, the user would stream the entire YouTube video to the Apple TV from their device. This process was very intensive on the device processor & Wi-Fi antennas because the YouTube video would be first downloaded to the user device & then retransmitted to the Apple TV, so Airplay could be jittery or flaky in that scenario. On the 4th Gen Apple TV's the workflow is different - Now when a user device wants to stream a YouTube video the User device & Apple TV communicate via a P2P network & then the user device will send the url for the youtube video to the Apple TV & then the Apple TV will pull up the video from the Ethernet connection it has, reducing the wifi load & typically creating a better user experience on the Apple TV.

So in your situation maybe try: 1) Try hooking up the Apple TV's to ethernet & see if that fixes your issue
2) Ensure channels 149-161 are not used by your wireless deployment if you can


We have this same issue and I've been working with apple since this past January (feels A LOT longer than that though) trying to figure it out. In our case, the 4th gen ATVs (we have 48 of them) are losing the ability to connect to wireless after losing power for a long period of time, or being unplugged from power (even momentarily), they will not connect to wireless with the profile we've installed on them. The only solution is to give them a hardwired connection and within 5-10 seconds, they're able to reconnect to wireless again with the installed wireless config they have.

The 5th gen ATVs that are 4k we've had no issues with. Apple has said they're unable to recreate the issue on their end despite having our config profiles that we've exported and sent them along with ATV diagnostic logs showing that they are losing the correct time/date and reverting to Dec. 31, 1969 which would make sense why they wouldn't work with any kind of trust cert. We tried other work arounds with different cert combos based on what we read on an Aruba AP forum, but no luck.

Our case number with apple is 100412506723 if you feel like calling apple and referencing it. At the moment, Apple has said we can do a PPI (some prepaid service to work directly with apple engineers) to further troubleshoot this issue, but I'm guessing it probably won't make a difference.

Our general wireless config we push out is configured accordingly:
auto-join supplied user/pass we've created 802.1x network
security PEAP with a trusted cert
*we are running WPA/WPA 2 enterprise.

Again, we have the same config pushed out to 4th gen and the 5th gen(4K) ATVs, but it's only the 4th gen that have the issue. The most obvious difference between the models is that the 4th gen has a USB-C plug and the 5th gen models don't.