Avid Media Composer Install and licensing

New Contributor

I am trying to install and license Avid Media Composer on lab machines using floating license.

Used Jamf composer to install the pkg for Avid Link first and then Avid Media composer with postinstall script

installer -pkg /“installer.pkg” -target /    the app install fine.

I tried to capture the license using another package.


But getting error when opening Avid Link


anyone knows how to capture the license?




We are using an Avid Floating license server and the following Composer capture works for us.

As for the installation... We use Avid's Media Composer Package installer (Set at 10 Priority), iLok's Package installer (Set at 11 Priority), and the Floating License installer below (Set at 12 Priority)

We have been using this method for a few years now...

Hope this helps.

Screen Shot 2022-09-06 at 3.42.08 PM.png


Do you capture the license as a pkg or dmg?


We capture it as a pkg.

New Contributor II

Did you have to do any permissions changes to allow it to run for logged in users?


New Contributor III


In case anyone else should stumble apon this topic, I spent ages trying to use Composer to package Avid Media Composer (AMC) 22.12 for Jamf Pro (aimed for a Silicon mac running Monterey). Suspicious Package showed the Installer was a package so - sheer blind faith - I upload the whole installer (in it's entirety - 2.2GB) in to the Jamf Cloud distribution point. Then attached to a policy, made the policy available via self service and did a trail run installation on to an Intel iMac running Monterey. And it worked. Avid Media Composter installed and ran to the license dialog.

Deploying the license (as per comments above) is a separate issue. As is testing to Silicon Macs. These are the next tasks on my list but hopeful this comment might save someone else hours of time.

Please note, my experience is with the latest AMC 22.12 (and hopefully all future releases) and it only installed the core AMC app and components (including AvidLink and PACE/iLok/license manager); not the optional additional app, Bluenote Titler Express 7. Best luck - YMMV
Thank you


I am also having the same problem now with Media Composer Ultimate 2023.3. I used to use the same files shown below by rroueau in Media Composer 2022, but now it no longer works with 2023.3.