Big Sur Google Drive for Desktop popups

Valued Contributor II

Has anyone figured out how to stop all these Google Drive for Desktop popups?

The desktop applications installs, the user runs the application and signs in, then a verification to verify you downloaded the app from Google, but then I see another popup to go into system preferences and deal with that 'ALLOW' and then it says to RESTART.

what a hassle.


New Contributor

Recently, I wrote a piece about how macOS Big Sur on M1-based MacBooks and Air laptops broke the Google Drive Backup & Sync tool. Because of this, I opted to turn back to my old standby, Insync--which I still stand behind. It's a great tool for getting your desktop in sync with your Google Drive. Mypascoconnect Not only that, it's considerably more flexible and powerful than what Google has to offer on their measly little desktop sync tool.

Contributor III

You should be able to suppress them all by adding a config profile with pre-approved kexts (or system extension). I did the mistake of assuming that the new version of G drive only would use system extensions but it looks like it depends on the Mac architecture so create one config for M1's (with system extensions) and one with pre-approved kexts (for intel Macs)

Valued Contributor II

Where are the values I need to use to create these configuration profiles?

All I have is the Google drive team identifier in my system extension configuration profile that I tested yesterday on a intel running big sur.

Valued Contributor II

@tjhall  yep i found that same discussion and created the config profile, now gotta test on both intel and M1 big sur.

hopefully i created the profile correctly, here is what it looks like.

Screen Shot 2021-09-01 at 9.56.17 AM.pngScreen Shot 2021-09-01 at 9.55.49 AM.pngScreen Shot 2021-09-01 at 9.54.37 AM.png

Contributor III

Followed the screenshots settings and still asked me to "Allow" and "Restart"

I got one to work with an intel computer with 10.15 on it with a kext. I noticed that there is a letter missing in the it should be  notice that there is a F missing from the first one.  Never got anything about allowing and never had to go security and privacy to do anythingScreen Shot 2021-09-08 at 3.22.50 PM.png

Ya, on 10.15 it works fine.  However if you try this with a macOS 11 device you still have to manually approve the text.  At least that is what I am seeing.

Also, M1 device with version 50 works just fine.  I didn't need any type of kext approval, it just worked fine.  Guess the M1 version doesn't use the kext.

On my M1's I am having the same thing no need for any system extensions needed.  On Intel with Big Sur still having issues with needing to approve.   Big Sur uses system extensions instead of KEXT