Blender 2.82a incorrect file permissions - quickfix

Contributor III

Posting this here because some poor soul might be searching for it in the future...
If you've been asked to deploy the latest version of Blender 2.82a and you've discovered it's DMG packaged file permissions are messed up from the official website, there is a quick fix to reset the apps file and folder permissions to 755 by running:

sudo find /Applications/ -exec chmod 755 {} ;

This appears to be an issue for any version after 2.79 and there is no fix in place by the developers yet for their official binary drag and drop installer.

You'll have to install it on your machine, fix the permissions using the above command via terminal and then package it using composer or another packaging program (avoid using snapshots when possible, drag it onto composer instead). Trying to package it without fixing the permissions first will fail as the Blender app devs have set the permissions to everyone - no access.

I found the solution here: but they don't seem to have twigged that it isn't just one person with the issue. The binary drag and drop installer on the official homepage has been packaged with incorrect file and folder permissions for macOS for the last several versions...

Also be sure to change the owner and group permissions of the app within Composer to Owner = root and Group = Admin.
Then apply the Owner and Group settings to all items with in the app using the cog icon at the lower right.
"Apply owner and group to and all enclosed items".


New Contributor II

Hi there, it seems like you have been able to get Blender installed successfully. Could you share in more detail the process you used? Is this in Catalina?

I opened composer on my Catalina test machine, took a snapshot, installed Blender, made the permission modification you suggested, and then took the second snapshot. The resultant .pkg file fails to install on any other Catalina machine, just after the admin password stage it fails stating the package is incompatible with this OS.

The installer downloaded straight from Blender did finish on my test machine, but the app crashed as soon as it was opened. On otehr machines, the package fails to install at all as per above.

Did you run into any of this?


New Contributor II

Log files indicate its trying to install to the System volume, did you also ahve to workaround this problem?

Package Authoring Error: Package contains system volume install location content. Installation cannot proceed since installing to the system volume is not possible.

New Contributor II

Just an update to anyone who may be reading. I found issues deploying with Composer, whenever I tried to install the resultant package I got an error message saying it was incompatible with Catalina. In the end, I took the Blender DMG, mounted it and ran:

sudo pkgbuild --install-location /Applications --component /Volumes/Blender/ ./Desktop/<yourPackageNameHere>.pkg

To build a .pkg for Jamf Pro. I did have the permissions issue snowfox described, so I just ran his fix. My plan is to create a policy that deploys my package then has a seperate script that runs snowfox's fix. Hope this helps.

Contributor III

Hi, sorry for the late reply. I try to avoid using snapshots as much as possible as it can include unintended folders and files. I installed blender (drag and drop) on my test/build machine. I then ran the below command from the terminal:

sudo find /Applications/ -exec chmod 755 {} ;

I then dragged the on to Composer and then I changed the apps file permissions in Composer so that they no longer referenced my logged in account as the owner. i.e. I changed the permissions on the app (in Composer) to Owner = Root and Group = Admin). I then clicked on the cog icon at the bottom right and selected "Apply owner and group to and all enclosed items". I then clicked 'build as PKG' on the top menu.

Installing the resultant PKG onto a clean test machine allowed me to run the app correctly on multiple accounts without any error messages popping up about permission settings or no-entry signs on the in /Applications.

I didn't have the other issues that you had. I think it's because you were snapshoting and I wasn't doing that. Composer supports app drag and drop instead of snapshot. My original post was incorrectly worded when I said 'capture'. I have changed it now to 'package'.

New Contributor

Thanks so much for posting this. It worked for me following the instructions in the first post to prepare a package for Blender 2.83 LTS. The permissions fix is still necessary for this version.

Contributor III

@Becci I actually found a better way of doing this since the original post.

Install Blender 2.83.3 LTS on your admin machine
Run it to remove quarantine prompts etc.
Drag and drop it into composer
Open the applications folder displayed in Composers right hand window
Click on the to see its permissions
Set the Owner = Root and the Group = Admin
At the bottom right you'll see the app permission settings are set to 700 read write and execute for the owner only (by default). Change this to 755 by ticking write and execute for the Admin group and Everyone group.
Now click the cog icon to the right.
Click - Apply Permissions to and All Enclosed items (this applies the permission fix within Composer without running any terminal commands.)
Click - Apply Owner and Group to and All Enclosed items
Now build the PKG and it will work. That's what I've been doing for the last few versions.

Contributor III



Thank you so much for this... It's been driving me crazy! I have always just set the permissions correctly in Composer, but no matter how many times I modified the permissions, it still came up broken on all of my deployments.

I am thinking I can just put the chmod in a post install script.

Contributor II

@kacey3, you've got the right idea, but you don't even have to make a post install script for this. It'll work just fine as an "Execute Command" in the "Files & Processes" payload of the policy you use to deploy Blender. de28353bca7d4b2c8d1c11b9eb1f2313

Thanks also to @snowfox for sharing the Terminal command. It works great this way.



Next question, is anyone else losing the app icon after deployment? The app works on all of my computers, but the icon is the generic app icon.

New Contributor II

This was very helpful! Thanks!