Can't Remove Shortcut from iPad

New Contributor III

Hey guys!

So today we came across an interesting issue with a few iPads. It seems that if someone goes to Safari and clicks on a page to create a bookmark and then saves it to the home screen, you cannot go and remove the bookmark. These particular iPads do NOT have a home screen layout profile setup and while they do have Restrictions payload, we tried allowing permission to remove both user and System apps and neither options allowed removal.

Anyone know if there is an option someone else I could be missing? I looked over every single checkbox in the Restrictions payload and the only others in effect are Passcode and Lock Screen so those should not be conflicting.

Any help or advice would be much appreciated!



Hey @aparten,

Do you have the Restrictions, Passcode, and Lock Screen payloads all in one configuration profile? If I remember correctly, I had some interesting issues when I attempted to deploy a Profile with the Restictions and Lock Screen payloads together. I've always been advised to only have one payload per configuration profile to ensure no conflicts occur between payloads.

If you do have these payloads all in one profile, i'd suggest trying to split them out into three separate Configuration Profiles and see if you have different results.

New Contributor III

@ejculpepper - Nope, good thought though. We've been doing individual profiles for each payload from the start.

New Contributor

Does anyone know if this issue has a resolution? In Safari, we did Share, Add to home screen. We can’t delete the icon. Tried reapplying the configuration profile, took out of scope and back in, re-started. Nothing seems to work.

New Contributor

I have the same issue. One of my teacher added a Safari web shortcut on the iPad home screen, and she cannot delete it, like for actual applications. How can JAMF allow supervised devices to delete only these web shortcuts?