Casper Imaging quit unexpectedly 8.61

New Contributor II

Via Net boot (10.7.5), running Casper imaging on a new computer, which is not in the Jamf database, once passed authorising the software to run you get "Casper Imaging quit unexpectedly" message. Ironically this doesn't stop the process from running as you can choose to ignore.

If the computer is in the Jamf database then Casper imaging works fine

Casper Imaging 8.52. works fine for both scenarios.


Honored Contributor

I ran into this yesterday and then I stupidly realized that I was running Imaging 8.61 against my prod 8.52 instead of my QA 8.61.

Worked fine when I was doing it right...

New Contributor

I'm seeing the same thing with 8.61. The App and the JSS are both 8.61, but I always get the "unexpectedly quit" notification.

My current workaround is to use Casper Imaging 8.6 to connect to the JSS (8.61).

Confirmed error on Lion and ML.

New Contributor II

Glad to see i wasn't going mad, having to use Casper Imaging 8.52 with JSS 8.61, as 8.6 has it's own bugs (namely spotlight turned off)

Valued Contributor II

Bugger. Looks like my weekly automated rebuild policy is not going to work if Imaging is quitting!

Valued Contributor

I am experiencing the same issue of Casper Imaging 8.61 unexpectedly quitting. This is with a clean install of 10.7.5. I discovered it as I was attempting to create a new NetBoot image. I haven't published the NBI on our Netboot server yet, so I don't know if it is still stable to use if you simply ignore the warning.

On 09-28-2012, I contacted JAMF Support and they created a defect ID.

New Contributor III

I'm seeing it with 8.6.2 as well. Tried imaging from 10.8.2 machine and 10.7.4 with clean installs of 10.7.5 & 10.8.1 to new machines.

I reported it to JAMF support

New Contributor

I just upgraded to 8.62, updated my Netboot image with the 8.62 Casper Imaging app and Casper Imaging quits soon after the 'Erase Hard Drive' task begins.

I reverted back to my 8.31 Netboot image and it seems to work. I will test throughout the weekend.

New Contributor III

Count me in too; constant "unexpectedly quit" errors with version 8.61. Reverting to 8.6 solved the problem.

New Contributor

What worked for me was making sure my NetBoot image was checked to run 'Diskless.' To confirm this, when in Casper Imaging, look at "Installation - /Volumes/Macintosh HD - disk0s2" This indicates the temp files are being written to the server and not to the local drive.

Thanks to Dan Kubley for this tip!


I'm having this issue on a netboot server with 8.62... just an annoyance though as it seems to work ultimately.

New Contributor

I'm currently on jss 8.62
I was also having this error until i recreated the netboot image again. 1) enable root account
2) change auto login with the root system administrator account
3) capture the netboot image with 10.8.2 server system image utility
4) resize the partition to 25GB.

The error went away. Give that a try.