Chrome 76.0.3809.100 Cannot run on this OS

New Contributor III

Anyone seeing this error on devices not running Mojave. It seems like every user that gets the Chrome update can no longer use Chrome unless they are running Mojave. Upgrading to Mojave resolves the issue, but we have a large number of devices on Sierra and High Sierra. 412d72f3a346407693335c6012382e2a


Valued Contributor

How are you getting the update out?

New Contributor

I'm not seeing any issues with 76.0.3809.100 on 10.12.6


No problems here on my High Sierra testers. Maybe redownload the package?

New Contributor III

I'm using a script to download the newest version and install it. I was using a config profile to ensure that Google Autoupdate worked, but I removed that when I started seeing problems. I'm assuming it has something to do with that, but it's weird that upgrading to mojave resolves the issue, but uninstalling, downloading directly, and re-installing doesn't fix the issue. I'm digging to see what changes in the plist because of the config profile, but I can't imagine that would prevent Chrome from working on older OS releases.

Contributor III

Had this on one 10.13.6 mini out of about three dozen. Still no idea yet what the difference was/is.