Configuration Profille Restrictions Desktop Picture Path

Contributor II

I'm trying to set the Desktop Picture using configuration profile > restrictions > functionality.

It just doesn't work if the Desktop Picture Path contains space either in the file name or folder name.

I've tried using " or "" or " or <space> all failed. Anyone know what's going on here? Thanks.


New Contributor III

Forward slashes.
This works, no backslashes nor quotes required:

/Library/Desktop Pictures/Desert 7.jpg
"You do not rise to the level of your goals; you fall to the level of your systems." James Clear

Esteemed Contributor II

I'm not sure if it's still the case, but be aware that at one point if you created a Desktop Picture restriction and then disabled it Jamf Pro would still include the path in the generated Configuration Profile. If you're testing that restriction, and then wondering why you can't disable it, it may still be doing that.