Connection failure: "The operation couldn't be completed. (Error 502.)"

New Contributor II

I received this error message on 5 machines this morning. I'm assuming that our policy to recon tried to run but couldn't because the user terminated their connection in the middle of it.
I just wanted to see if anybody else has seen this before.

Executing Policy JAMF Recon
Running script JAMF Recon...
Script exit code: 1
Script result: Retrieving inventory preferences from https://
Finding extension attributes...
Locating applications...
Locating accounts...
Locating software updates...
Locating package receipts...
Locating plugins...
Locating printers...
Locating hard drive information...
Searching path: /Library/Internet Plug-Ins
Searching path: /Users/[domain username]/Applications
Searching path: /Users/[Local Admin Username]/Applications
Searching path: /Applications
Locating hardware information (Mac OS X 10.14.5)...
Gathering application usage information...
Submitting data to https://
There was an error.

Connection failure: "The operation couldn’t be completed. ( error 502.)"
Error running script: return code was 1.


Contributor III

im seeing this on some computers all of a sudden too

Contributor II

I second this as well.

Contributor II

@Mateo137 Do you have a ticket open with JAMF on this or have you got any more info on your situation?

Valued Contributor

@CorpIT_eB @hdsreid @Mateo137

Have you gotten a resolution to this? We started seeing this just after moving the a jamf cloud instance last week. I've opened a ticket with Support but they can't finding anything yet.


Im getting the same error when uploading pkg files. Seems to be very random. Opened several tickets, when I do they do some tweaking and then it works for a bit but will fail again.

New Contributor

I'm seeing this error during recon on several of our machines as well. Did anyone ever get a resolution?

New Contributor

I'm seeing this on a few too

New Contributor

did this get resolved - now seeing also


ill add to this that ive been seeing it sporadically for a bit.

1 of a few things can happen, and ill list in them from least to most common:
1. either it fails the recon, and actually fails, then it says it will upload the data on next check in. probably internet related, but 1/100
2.recon fails with the 502, but if you refresh JSS itll show the updated info (i can only verify on the 2 EAs that im keeping an eye on) - 1/20 or so

maybe just a glitch, maybe a fluke, but 99%+ of the time, at least it seems to me, the recon is actually going through.

granted, im us-east-1, so im getting maintenance for at least another 3-4 hours.
maybe thatll fix something.

on that note, does plist changes in config profiles work for you guys?
i see the option to choose the jamf stuff along with what version mau, but when it comes to the actual plist settings, its blank 😞

New Contributor II

I am getting it too, sent in trouble ticket to JAMF.

New Contributor III

any update on this any one?

New Contributor III

I'm getting this often as well!

New Contributor II

I am having the issue as well and is affecting my whole provisioning workflow.

New Contributor III

Same issue also for me with a script "sudo jamf recon" on the Self service... I don't know why

New Contributor III

Same issue while uploading a small pkg. Any resolve?

New Contributor III

Has anyone resolved this? Seems to be part of an issue we are having with devices not checking in.

Contributor II

Same problems here since this morning...