Dashboard Loading Issue

New Contributor II

Lately I've noticed (this also happened to my coworkers) that when I log into JamfPro I find my dashboard loads for about a split second then disappears. I've tried the following steps to troubleshoot the issue.

  1. Clear my cache, restart browser.
  2. Try a different browser (Chrome, Safari, Firefox)
  3. Removed each item on the dashboard hoping that one item was causing the isssue.
  4. Tried added an item that wasn't there before.
  5. Had my coworker do the same steps with their account.

Has anyone else run into this issue?
Anyone have a fix I haven't thought of?

Honestly it's not a big deal, but I'm of the mindset...if it's there...it should work.



+1 Same issue, all other JAMF functions seem to work fine, however the dashboard never loads. Constant spinning wheel.

New Contributor

+1 - happens to me a lot, I do exactly the same. The only thing that sometimes resolves the issue for me is to remove everything from appearing on the dashboard.

New Contributor III

+1 This just started happening to me too, everything else seems to work fine.

New Contributor III

We noticed our Dashboards taking progressivly longer to load until this morning when they completely fail. Nothing but the spinning loading indicator forever.

New Contributor II

Same here, as soon as i choose any Policy to add to my Dashboard, it will spinn forever.

New Contributor

Same here, is there no fix for this?

New Contributor II

We managed to fix it by deleting a computerobject we added just before the dashboard problem occured. Dont know what exactly caused it, but as soon as we removed it from our jss everything went back to normal

New Contributor II

So disappointing how I see many many issues never resolved in theses forums.
I have the same problem. Not all that thrilled with how long it takes to actually get help from someone at Jamf support that knows how to fix the issue. Sometimes it feels like it's just not worth it.....

New Contributor II

I cannot relate to your support case but in mine the support was really fast and reliable, in the end they helped deleting the problematic object out of our cloud as we could not even delete it anymore.