Dashboard Loading Issue

New Contributor II

Lately I've noticed (this also happened to my coworkers) that when I log into JamfPro I find my dashboard loads for about a split second then disappears. I've tried the following steps to troubleshoot the issue.

  1. Clear my cache, restart browser.
  2. Try a different browser (Chrome, Safari, Firefox)
  3. Removed each item on the dashboard hoping that one item was causing the isssue.
  4. Tried added an item that wasn't there before.
  5. Had my coworker do the same steps with their account.

Has anyone else run into this issue?
Anyone have a fix I haven't thought of?

Honestly it's not a big deal, but I'm of the mindset...if it's there...it should work.



+1 Same issue, all other JAMF functions seem to work fine, however the dashboard never loads. Constant spinning wheel.

New Contributor

+1 - happens to me a lot, I do exactly the same. The only thing that sometimes resolves the issue for me is to remove everything from appearing on the dashboard.

New Contributor III

+1 This just started happening to me too, everything else seems to work fine.

New Contributor III

We noticed our Dashboards taking progressivly longer to load until this morning when they completely fail. Nothing but the spinning loading indicator forever.

New Contributor III

Same here, as soon as i choose any Policy to add to my Dashboard, it will spinn forever.

New Contributor

Same here, is there no fix for this?

New Contributor III

We managed to fix it by deleting a computerobject we added just before the dashboard problem occured. Dont know what exactly caused it, but as soon as we removed it from our jss everything went back to normal

New Contributor II

So disappointing how I see many many issues never resolved in theses forums.
I have the same problem. Not all that thrilled with how long it takes to actually get help from someone at Jamf support that knows how to fix the issue. Sometimes it feels like it's just not worth it.....

New Contributor III

I cannot relate to your support case but in mine the support was really fast and reliable, in the end they helped deleting the problematic object out of our cloud as we could not even delete it anymore.

New Contributor III

Yeah this is happening to me every day at the moment. One day Safari worked ... the next day it doesn't. So, I use Google Chrome and then it works for a day or so and then when you log in, it just flashes, feel like I'm going to get seizures watching it.


Today, I tried both Safari and Chrome and can't get to the Polices or Prestage enrollment, just spinning circles.


Support ended up telling me that it is a known SSO bug. I fight with it all the time. Sometimes clearing cache, cookies and temp files fixes the issue. Sometimes opening a new tab and trying to load the page again will fix it.
I submitted fiddler trace captures to Jamf showing that there is a hang-up with the SSO process when it authenticates with Azure and it sits in a repetitive loop but Jamf support did not seem interested in finding the solution. I know that sounds a bit negative towards the support team and I'm sorry for that but it is frustrating when you have the error documented and there is still no solution offered.

New Contributor

I have been suffering this issue for quite some time and finally opened a ticket with JAMF Support.... and then figured out that it was a poorly written Chrome Extension: turned off the extension and all of a sudden my dashboard stayed visible.

Yup. Same problem here. So frustrating.