DEP enrollment doesnt work

New Contributor III

We are using apple business manager in my organazation.  Our jamf pro sync with azure ad , when we try to enroll a new mac os device its ask e-mail password but does not the accept . Because of that we cant pass this step and couldnt open the device. 





New Contributor II

I'm having a similar problem, although we use our own AD. On boot and setup, it never gets the "Remote Management" screen. I can bypass it and complete the setup manually, including enrolling in Jamf Pro. I've checked with our ABM people and they say it was added to ADE correctly. I've talked to Apple support and the technician checked and said it was correct at their end but it isn't correct as the Jamf Pro server. From what he could see the profile name was "NA". It is "not fully supervised"

I don't know it this matters, but our problem machines are M1 devices.

Release Candidate Programs Tester

Something is likely amiss with your SSO and/or Cloud Identity Provider configuration.  The login window you see in your Enrollment Customization, when tied to Azure AD, should be a standard Microsoft/Office 365 login pane:Login.jpg


For reference:  Azure AD Integration and Enrollment Customization Settings 


Hi @jcarr it depends which MFA Status in Azure you use. For environment with MFA Disabled in Azure you have to use enrollment login page and the LDAP Authentication pane in Enrollment Customization.

@hdagidiryou have to create an Enrollment Customization with Pane Type LDAP Authentication. Then add this Enrollment Customization Configuration to your Prestage Enrollment Configuration. Require Authentication must also be checked. This works fine for us. You can even prefill the created user account afterwards with the login information from the Email Address you provide to authenticate if you wish.

Contributor III

To add we get the same initial prompt when we enroll our Jamf devices. We've enrolled 30 mac's, but we have 2 users that cant' get past the initial logon. It's like it doesn't except the password.

New Contributor III


I solved the problem. Thank you.