DEP Pre-Stage Creates Unmanaged Computers for 1-2 Hours


Recently we updated our JSS to 9.100, previously 9.93, and since then our DEP Pre-Stage enrollments are stalling out for about 1-2 hours (no exact times) before the actual enrollment takes place and enrollment policies kick in. There are a few other threads on here about DEP creating unmanaged computers, but none mention the 1-2 hour wait. I wondered if anyone had seen anything similar, or may have a solution that they've uncovered. I've tested this on 10.12 and 10.13 machines with the same result, so I've ruled out a weird High Sierra "thing". I've tried authentication being on and off, creating a new local admin being on and off, unchecking and rechecking all the options at the "bottom" of the Pre-Stage setup; nothing changes. The computer gets the Pre-Stage trigger, gets the computer name entered into the JSS as DEP - Serial#, but shows as unmanaged. Then magically 1-2 hours later starts the enrollment process. The jamf binary does not get installed initially, but, again after that 1-2 hour window, shows up and the machine enrolls properly. Any thoughts or suggestions would be welcome because I'm starting to get a bald patch from scratching my head!


Valued Contributor III

As posted in another thread, we have to restart ours before they install the binary and start doing the rest of the tasks. You might find the two hours is the point at which the person gets bored and reboots.


@Look I saw that post and that actually sort of works, but the 1-2 hour thing was just me running a timer before things actually kicked off. I'd like to find a solution either way as before the upgrade we did not have this issue. Asking a customer/user to reboot after they just turned their computer on for the first time just doesn't seem right to me.

New Contributor III

@tdclark did you ever find a solution to this?