Device was busy. Will try again.

New Contributor III

I know this has come up a few times in the past but mostly for iOS devices. I'm having an issue that started today where I deployed around 10 new configuration profiles to around 500 Macs and it started out fine with computers completing the installation but now as computers check in, they're all showing "Device was busy. Will try again." I've cleared all of the pending and failed commands but this is all I get now. We're on Jamf 10.19 cloud. The computers are running various operating systems, mostly 10.14 but some 10.15 and some below 10.14.


New Contributor III
New Contributor III

Most times when a device is show it's busy in Jamf, it could be various reasons:

  • Device has been rebooted, and hasn't been unlocked since restarting.
  • Device is off
  • Device is currently downloading an OS update or application.
  • There may be other situations in which this can happen, depending on the OS version, and network environment.

If you have one device near by, does the command status change if we connect to a different network or hotspot? - Will need to clear/cancel all pending and failed commands and send a blank push or if you run: sudo jamf recon

If we're having APNs issues, any remote command such as wiping may not work until we get this error resolved.


Any resolution to this? I'm deploying an 802.1x profile to about 100 Macs - all on Mojave - and around a dozen of them are getting this error.


I am also having this issue....

New Contributor

I'm starting to see this in one of the environments that I manage... Has anybody figured out what the resolution for this was?

Contributor II

@afunk @McGinn @boanes.tcna Have had this happening to a handful out of ~1800 ipads. The ONLY solution I have found is to send the clear passcode command. Restart and unlocking has no effect. RenewMDM, Config profiles, inventory, etc all just stay stuck at device busy. Send Clear the passcode and almost immediately everything else goes through.

I was STRUGGLING with this. Thank you so much - your solution fixed it immediately!

This fixed it!

New Contributor III

I'm running 10.27.0 on-prem and am seeing this issue, but began seeing it on 10.25.0. We have about 10.5k active iPads and am seeing this in several devices, but not widespread. Also, when a device exhibits this issue, it's only with certain management commands.

For instance, I have a lost iPad I'm trying to locate for a teacher. Some commands (Restart Device, Shut Down Device, Update Inventory, Clear Passcode, and Renew MDM Profile) work just fine every time I issue them to this iPad. However, there are about 8 or 9 automatic app installs and EnableLostMode that are eternally returning Device was busy. Will try again..

Unfortunately, clearing the passcode hasn't helped.

New Contributor II

Hello all,
My location also started seen this issue.

New Contributor II

Hey all, Be aware there is this known issue

If there two Volume Purchasing locations integrated with Jamf Pro that contain a license for the same app and a device is in the scope of both apps, Jamf Pro can fail to assign a license for the app. This can also prevent all subsequent MDM commands from being sent.

we had to contact jamf to know that this was a known issue. Descoping the duplicate applications helped

New Contributor III

This started happening to me yesterday.  I'm just pushing out a Google Drive app update to student iPads.  I got 70 done without any issue, and now all-of-a-sudden the "device is busy" error appears and won't go away.  I thought maybe whatever was causing it would correct itself overnight, but I was wrong.

New Contributor III

Im seeing this as well with 2 configs across org

New Contributor


New Contributor II

Any updates here? I'm seeing the same issue with installing Procreate on the iPad Pro's in my organization.  

The install has gone through successfully on all of my other devices, but it's stuck in "Device was busy" for the iPad pros.

I've tried power cycling, changing networks, clearing the passcode, removing from scope and re-adding, nothing works. 

Any updates would be appreciated!

New Contributor II

So typically I have noticed this error comes up after a device has been rebooted - but NO user has logged in. Try having a user log into the device!