Figma desktop app is not running after upgrade Ventura

Contributor II

I package Figma desktop application after download the app as .dmg via composer and deployed thorugh policy with no issue. It was working fine on macOS Monterey but after upgrade to Ventura it is not working saying corrupted. I also tried to re-install from policy still get same error. But if I right click the app icon from docker and click "open" a new window pop up from there if I click open again that will launch Figma desktop and this need to do for the 1st time after upgrade. Any suggestion for that. Any one know how I can kipp Figma process running that way i will script to remove the Figma App from /Applications folder and re-install to see that resolve the issue or not.


Contributor II

I am very sorry to post Screen shot, i was trying to type the steps but giving me error. So Post screen shot.

Screenshot 2023-01-23 at 3.55.23 PM.png

View solution in original post


Honored Contributor II

Have you tried manually installing the application without JAMF being involved at all? You may just need to update your package with new source files or a current version of Figma. Making the package on Ventura probably would not hurt either.

There has no Installer for Figma desktop app. The App downloaded as .dmg and when you unzip that will give you .app and move that to your application folder to use that. I make a package that .app from my machine and deploy via policy for mass deployment. But for some reason that got corrupted after upgrade to Ventura. This is error message user getting after upgrade

Screenshot 2023-01-18 at 10.19.14 AM.png

So I tried to kill the running Figma App right before Upgrade and then upgrade to Ventura and launch Figma got different error


But that launch perfectly after click on open 1st time.


New Contributor II

Figma was an exercise in frustration as it downloads a stub installer that has to be run by an account with admin rights. You can either push the app to the users Applications folder or I opted to script the download instead as it's always up to date. See below for the Apple Silicon version. I have a separate one for Intel. Hope this helps.



cd /tmp

latest_version=$(curl -fsSL "")
curl -O${latest_version}.zip
unzip -o Figma-${latest_version}.zip
rm -r Figma-${latest_version}.zip

sudo mv /Applications/
rm -f

Contributor II

@joboo72 If I want to do that then I had to download Figma app from figma website from each endpoints which we don't want. So I chose to package with composer. But when I deploying through Jamf via package then the folder permission become as below

drwxrwxr-x@ 3 root         wheel                     96 Jan 23 09:55

And when I am trying to change permission of that folder getting following error
chmod: Unable to change file mode on /Applications/ Operation not permitted

And I am trying to remove that installed version getting following error after ran: rm -r /Applications/

override rwxrwxr-x root/wheel for /Applications/

BTW I can remove or change permission if Figma never launch after install. But if I launch the app then that will not allowing anymore though i already kill Figma App with command: killall Figma. 

Anny suggestion is helpfull.


Contributor II

Finally I able to remove Figma from /Applications folder with the following command

rm -rf /Applications/

that worked. Now I am trying to package this new version of Figma on macOS Ventura and deploy that to macOS Monterey machine prior to upgrade. Will see that fix the issue or not.

Contributor II

I am very sorry to post Screen shot, i was trying to type the steps but giving me error. So Post screen shot.

Screenshot 2023-01-23 at 3.55.23 PM.png

New Contributor III

I was able to get this install working by 
1. Downloading the DMG, mounted it. 
2. Dragged the App into /Applications - DO NOT RUN/OPEN THE APP YET

3. packaged the App using composer - IMPORTANT - do no launch the App YET. Package it before you run it for the first time. To by pass the Download and Install. 
4. Deploy the pkg via Jamf, and run the below command (via Jamf's execute command payload). 
5. By having the Jamf Binary run this command, it will run the download and install process for the user, and they shouldn't see the "Damaged" error. 

That worked!

This also worked for me - thanks! Didn't have to do step 4/5 but yeah - thanks!

New Contributor

Hi all, there is a simpler solution to this issue. The reason why it is failing and marked as damaged is because the application contains attribute flags of "".

You can confirm this by running the following command:

xattr /Path/to/

In order to fix this, run the following command on the application:

xattr -rc /Users/UserName/Downloads/

This will clear the flags recursively within the Figma App allowing you to drag the app into composer, package it up, and deploy on any machine. Keep in mind that clearing flags set on files/applications by the OS can be dangerous to security. However, if you have to do so, make sure the file(s) are safe.