FileVault Issue - Help!!! Cannot Encrypt Drive

pblake
Contributor II

So I decided to post this issue here as I have been working on this all weekend and searching the internet and found nothing helpful. Here is the issue.

I tried to enable FileVault on my 10.9.4 MacbookAir4,1. It goes through the normal motions, I see my recovery key, I choose whether or not to store it with Apple and then it reboots. After it reboots, I login to the grey FlieVaulted screen and the machine starts up. I look in System Preferences - FileVault and I see that it is encrypting.

When I come back after 10 or 15 minutes. I get the following error.
"There was a problem enabling FileVault.
Problems were encountered with the disk "Untitled 1". Please turn off FileVault, verify and (if necessary) repair the disk with Disk Utility, and then try enabling FileVault again."
See Screen shot here: http://i.stack.imgur.com/NW5KE.png

When I click on the Turn off FileVault button, I get the normal are you sure you wan tot turn it off message, and then I get the screenshot above again about the problem. Then I get the following message:
"Disabling FileVault Failed
An error occurred while reverting the disk. (Error: -69755)"

Here are the things I have tried to fix this issue.

I have repaired the disk and permissions. No joy. No errors even come up.
I have erased the drive and re-installed same thing happens.
I have erased the drive, re-partitioned it Master Boot Record, then re-partitioned it back to GUID, and re-installed. - Same thing.
I installed 10.8.5 instead of 10.9.4 - same thing.

Why can this drive not be encrypted? What is the issue? Any ideas anyone?

5 REPLIES 5

rtrouton
Valued Contributor III

@pblake,

Would you please run the following command in Terminal and then post the resulting output?

diskutil cs list

Thanks,
Rich

pblake
Contributor II

@rtrouton - thanks for the suggestion. I did the whole diskutil cs list, unlock, then revert with my udid. From your blog, I get the same error that it cannot be reverted. When I wipe the machine and do a cs list. There are no encrypted volumes. I am having this problem no matter what I do even after complete wiping the machine and volumes.

I'm thinking it is a bad ssd at this point. I'll do it again for you once the OS re-installs. I had wiped it again.

MAD0oM
Contributor

Experienced some of the issues you're describing. Not sure if its related to 10.9 but if i would image using casper id get that error. Typically with portable machines, id image with fresh OS from USB stick and then join manually to the JSS (your company.com:8080/enroll) then id go ahead a use casper remote to do my last so far it works...

randy
New Contributor

any luck with a 10.7.x Installer/recovery partition? that seems to be able to erase the drive and remove all encryption.

pblake
Contributor II

I've tried all 3 OS's. No luck. I can unlock and wipe the machine. I cannot successfully encrypt without the errors in my post. I've wiped it completely 6 times already. I have any appointment today with Apple as I think it is a bad ssd.