GlobalProtect - stop auto connection

New Contributor II

Hey.. Does anyone know how to stop GlobalProtect from autoconnecting to VPN?

Our clients authenticate through Google, so each time you boot up, GP is auto connecting and it throws up a big sign-into Google window and it's quite annoying.

Maybe a plist setting?




Valued Contributor II

I was unable to stop the auto connection. I tried for about 2 days.  : ) 

Valued Contributor II

I think there is code to stop auto-connection, however, it has to be connected to enable and configure from the server-side I think. This was about two years ago so it could be different now : ) 

Valued Contributor

Hi everyone, I found this site that mentions how to modify the launch agent.

Valued Contributor II

Not 100% sure that I tried exactly that configuration of the plist, I am 100% sure that I tried creating a plist before and after the install over the top of the one that gets installed by the GP and I sort of remember that it gets overwritten with one that was stored in the GP app. That said please don't let my bad memory stop anyone from trying  : ) 



New Contributor

I think this needs to be done on the firewall level you need to allow user to disconnect that will stop auto connection.