Google Chrome and Experimental QUIC protocol

New Contributor III

Good Afternoon All,

We are using the Google Chrome Master Preferences file for deployment but has anyone had any luck disabling QUIC via this method or mdm profile?

chrome://flags/ Experimental QUIC protocol



New Contributor II

Did you ever find a solution to this?

Contributor II

If you are a Google Workspace shop, you could first push a config profile that forces sign into the browser, making people sign in with their corp creds. After they sign in, Chrome would get 'Cloud' policies from Google Admin, which has a setting to disable QUIC:

Screenshot 2023-06-21 at 5.06.29 PM.png

Also, whether you set this via config profile or through the admin console, it looks as though it is being enforced, even though when go to chrome://flags and 'Experimental QUIC protocol' it may still say 'Default'.

chrome://policy - QuicAllowed should be 'false'

Another test would be a website like this:

New Contributor III

If you have a config profile or plist for your Chrome config I believe the key you want to add is QuicAllowed boolean true/false. Reference is here:

New Contributor II

I've tried to disable this through the configuration profile but it's not working for neither options. If you set the value to true or false, it will show as Default.
Have you find any good solution for this?

New Contributor

Did anyone found a solution to this?
Setting the value to true or false, also still shows as Default in chrome://flags#enable-quic

Valued Contributor II

Hey guys, I talked to Google about this and saw the same thing. When you push the profile for QUIC, try this in Chrome: chrome://policy?

The policy value does say false despite saying "default" when using chrome://flags#enable-quic

New Contributor II

@obi-k  do you happen to have a screenshot of how the policy is setup in Jamf? I cannot seem to figure it out. Thanks in advance.

Valued Contributor II


Screen Shot 2022-05-17 at 2.01.52 PM.png

Screen Shot 2022-05-17 at 2.02.03 PM.png


New Contributor II

Awesome! it worked. Thank you so much.