Having trouble assigning students to VPP purchases

Contributor II

I'm having a big problem. I'm trying to assign 11 students into the VPP Assignments/VPP Invitations area (our production Jamf Pro server is still on 10.15.1 due to various reasons with the central services group so the Invitations area still has the old name).

Of the 11, 6 went in just fine. The other 5, however, don't show up in the list to be able to add. They do, however, show up when I do a search on our local directory, and they even show up in the local account creation area in Jamf when I try to create a local user, so the directory is finding them.

The only thing I can think of, but can't verify, is that possibly the user IDs that are not working have never logged in on a lab machine that is controlled by Jamf. I don't know if that makes a difference, but with all this COVID stuff and the campus being shut down, it is possible. I also recognize a few of the user IDs that do work from last year. That may be relevant or a red herring.

We did do this at the end of last semester with a bunch of students with directions from our Apple SE, and it worked pretty well (we had issues with one student, but they somehow cleared up). I've copied him in on this message as well, just because I'm sending up rescue flares at this point.

Anyway, any idea how I can make this work for the remaining 5 students? This is an iOS program called FiLMiC Pro and it is going to student owned devices that are not managed by Jamf Pro, and we do not want them to be managed. This worked last year just fine, but I think probably everyone had logged into a lab machine at that point. Is there something that I can do to get those user records to show up in Jamf so that I can get this app to these students?

This is kind of a rush as the faculty just got the list of students to me. We are still in a level of chaos mode since we are still working from off campus. I would really appreciate any help, and would gladly bribe folks at the next in-person Jamf Nation conference! I did alert our Jamf Success representative and it looks like there is a case open, but I wanted to see if anybody in the community had an idea so I can get this working and avoid sitting here with a stomach ache... :-)

I'm hoping this is a simple, "Oh, you just do this." kind of problem.

Thank you for any help you can provide.


Contributor II

Sorted this out. Just had to figure out how to create users instead of user searches. The similarity of the pages fooled me... sigh. I'm going to have to start thinking about retirement pretty soon. :-)