Hidden admin account not hidden

New Contributor III


I use the management section when creating a new configuration to create a hidden user account, and it will create the account. But it is not hidden. There is also a quickadd package that does the same thing (can't create the quickadd package without adding the account). If I do not add the account with the configuration, and just use quickadd, I cannot login to the account. If I use the configuration option (plus quickadd to get it into JSS) then it works, but it is not hidden. Confused yet? Any help would be appreciated.


New Contributor

Hi. The 8.6 upgrade broke this for us as well. If you create a new configuration it will work again. Another option you can do until a fix is found is to run a script to hide 500 users:


Hope this helps,


New Contributor III

New Contributor III

Hi Mark,

I did create another Configuration, but it had the same results(no worky). I will try the script method for now. Thanks!


New Contributor

--Correction-- This issue has returned for me even with the updated installer. As dzmudzki mentioned. It appears to be a glitch with any packages being installed at startup.


I was having the same issue. I figured out that it was my Java installer causing the glitch with 8.61.

I downloaded the newest Java installer from Apple.com and my images started deploying properly again.

I hope this helps,

New Contributor

We recently upgraded our JSS to 8.62 from 8.52 and now have an issue with an Image Configuration. As part of the configuration we have "hide this account from the login window" box ticked but the user account appears on the login window.

We have done some testing to troubleshoot the issue:

Create new configuration with Vanilla image only, no issue found.
Create new image with a package applying at the same time as the image is laid down, no issue found
Create new image including a package applying at the imaging time(first run), hidden account shows at the login window

On the reimaged machine where the hidden account shows on the login window we run the terminal command:
sudo defaults write /Library/Preferences/com.apple.loginwindow Hide500Users -bool TRUE
Restart the machine, fixed the issue.

We added the script running the above command after the imaging, no luck. Seems like the com.apple.loginwindow.plist was either removed or overwritten when you have package/script run at "First Run". We compared the content of com.apple.loginwindow.plist on those two machines and they differ:

Machine reimaged with Mac OS X image only has Hide500Users entry set to true.
Machine reimaged with Mac OS X + packages installed at the imaging time do not have the Hide500Users entry.

The work around would be to have a policy to run the script to hide it but still the account can be send after first restart before the policy kicks in.

Running the QuickAdd.pkg works fine, machine is submitted to JSS and Hide500Users entry appears in the com.apple.loginwindow.plist file.

Hope it helps. We logged a ticket with JAMF Support to see if they can advice on it.

Contributor II

DZ .... you da man!! This issue just popped up for me!!