How to get Box Edit to Install Properly


I'm attempting to roll out Box Edit to my company.

I see Box even has a support article for deploying specifically with Casper, however it doesn't appear to work.

I've created my installer via Composer [I've tried Normal Snapshot and New & Modified Snapshot methods for creating the installer DMG], and the proper files get moved into place, however here's the missing piece.

There's a file inside Application Support > Box called "Box Local Com Server" that needs to be launched [double clicked, which opens no windows or anything] before a web browser will pick up on the fact the Box Edit exists, and then work properly on the website.

It's immediate. I can run my policy, everything moves into place, go to website, Box Edit is not recognized. Go to Finder, launch "Box Local Com Server", go back to browser, refresh page, Box Edit recognized and works as expected.

I discovered this through lots of trial and error.

Has anyone run into this or have a fix for this? Is there an easy JAMF way/command to launch this file after install? I assume that a special open command method might just break down the line, but if that's what I have to do, I guess that's life. I'm just not sure how to accomplish that.



Once I wrote out my whole explanation, I was one google away from placing an open file command into the policy and getting this to work... disregard...adding

open ~/Library/Application Support/Box/Box Edit/Box Local Com

to the policy execute command did the trick.


Nevermind, that doesn't seem to actually do it, the next day I went to and it's prompting me to install Box Edit again.

Anyone familiar with this install?

Valued Contributor

I've tried it based on their instructions but it always failed to load the box and the box local com on any account other than the one used to capture the install.

I got round this by creating a launch that just launches the 2 apps each time a user logs in.

I've even opened a ticket with them to see why their method doesn't work and so far haven't had a working solution back from them.

New Contributor III

So I have been able to get this to work via a modified script, originally written by 'bryson3Gps' on Wordpress:

Their script is dated (from 2013) and also includes Box Sync, so I only used the section relevant to Box Edit. You will need to add the word 'edit' as your "Parameter 4" when creating the Policy via Jamf but otherwise it works great. Only minor user interaction at the end to click "Install". If anyone can assist with getting this to be a silent step it would be much appreciated!


Pass the following from the JSS Parameter 4 to select the script's action:

edit: Install / Uninstall Box Edit

If either service is already installed the app will open with an "Uninstall" option

Error Codes:

0: Script executed successfully

101: The downloaded file did not pass the checksum test

102: The downloaded Box Edit DMG failed to mount


if [[ ${installerOption} = edit ]]; then echo "" echo "Downloading Box Edit" webCheckSum=$(curl -sI | tr -d ' ' | awk '/Content-Length/ {print $2}') curl -fkS --progress-bar -o /tmp/BoxToolsInstaller.dmg fileCheckSum=$(cksum /tmp/BoxToolsInstaller.dmg | awk '{print $2}') if [ $webCheckSum -ne $fileCheckSum ]; then rm /tmp/BoxToolsInstaller.dmg echo "The file did not download properly, Exiting..." exit 101 fi echo "Mounting Box Edit DMG..." hdiutil attach -quiet /tmp/BoxToolsInstaller.dmg if [ $? -ne 0 ]; then rm /tmp/BoxToolsInstaller.dmg echo "The Box Edit DMG failed to mount properly, exiting..." exit 102 fi cp -fR /Volumes/Box Tools Installer/Install Box /tmp/ hdiutil eject -quiet /Volumes/Box Tools Installer/ rm /tmp/BoxToolsInstaller.dmg echo "Opening the Box Edit Installer app" open -a /tmp/Install Box osascript -e "delay .5" -e 'tell application "Box Edit Installer" to activate' fi

echo "Finished"
exit 0