Imaging Error

New Contributor

Every once in a while when initiating an image we get the error:

"An exception of class NilObjectException was not handled. The application must be shut down."

Has anyone run into this? We are running jss 8.71 on 10.8.4 server.

Thanks in advance


Valued Contributor II

Are you booting from a Netboot image and launching Casper Imaging from that?

Edit: If you are using Netboot, then I would second what gachowski suggested. I made those changes to our Netboot system and it fixed the error message you listed.

Valued Contributor II


Do this : )

Jamf support recommend this to me and others in Jamf Nation, solved a lot of issues for me.. Looks like a lot of work, but it's just replacing one file and the file is on the page about 1/2 down.


New Contributor III

I went through this for a long time, and before 8.71 the issue didn't even give an error, just crapped out. After trying the above and that not working, I finally went to NetSUS appliance and haven't looked back. I'm using VirtualBox for the vm, so no additional expense

New Contributor

Thanks @gachowski that worked for me. just dl and replace that .netboot file and good to go.