iOS 11 iPads disconnecting from WiFi and asking for Password

New Contributor


I've seen a few posts on this issue and did not see any resolutions or workarounds. Those posts were all when iOS 11 released, and I haven't seen any since.

We are using WPA2 Enterprise LEAP to authenticate to our production network. The iPads connect, but after 2-4 days they disconnect and ask for the password, which is stored in the configuration profile. My workaround is having the user connect to an open network, then I remove and re add the WiFi profile. This only lasts for 2-4 before I need to do that again.

This is a single payload profile. I have tried creating a brand new profile, which does not help. We are using Cisco hardware.

Does anyone have a fix for this, or at least a temporary workaround? Apple is aware of this issue and I am sending them iPad log files as per their request.


New Contributor

We are having the same exact issue. JAMF suggested we replace the old profile with a new single payload profile. We have Meraki AP's (Cisco). It's not happening to everyone. But, there is a significant number daily. On a small test group, we tried a new profile. We haven't seen it re-occur yet, but it's only been a couple of days. Before this, we also used a 'restrict to managed network' profile to keep the iPads from going on to our Guest network. That worked great for a while, then it stopped working as well. We have since removed it. Hope this gets a fix soon.


We aren't seeing this but I have witnessed at least a dozen or so student and staff iPads with iOS 11 randomly have auto join turned off. I don't push this particular network via a profile and the one that I do is working without any issues on 11 +. We're on Meraki AP's as well.

New Contributor II

Get in touch with Cisco TAC, there is a known issue that Apple and Cisco are working on. Something about not prompting for a password when a deauth 15 happen on a device that has a profile. They are asking us to update our controllers, not sure if that will fix the issue or not, crossing my fingers.

New Contributor

Thank for your responses everyone. Now I know I'm not going insane.

I will update this thread if I hear anything back from Apple.

Contributor III

We have been seeing random issues with WiFi and our Meraki APs all school year. We have MR32s and the issue seems is isolated to iPad 5th Gen and Air 2 devices (which use 802.11ac and have 2 antennas). We had a case open with jamf and they said it's problems with our network. We're sending debug logs to our SE at Apple and Meraki, everything is up to date. I'd be curious to know for the other people that are having problems what gen devices and APs you're working with...