iOS IKEv2 VPN - Machine Auth & EAP Auth Issues

New Contributor

I'm in the implementation/testing stage for iOS device deployment at my org, and one of the requirements is to setup a VPN profile. Our VPN is IKEv2 protocol with Machine authentication as well as EAP Authentication using username/password.

The issue I'm experiencing is when I'm configuring the VPN Payload and i go to save it, the EAP Authentication method switches from Username/password back to Certificate. I've tried editing it back to username/password, as well as scrapping and re-creating the entire profile but it keeps happening. I've also tried creating the VPN profile using Configurator 2 and uploading it to Jamf, but the profile looks wonky and won't allow me to save.

Has anyone else experienced this?


New Contributor II

Having the exact same issue this side. I've successfully managed to force the connection to EAP user/pass by including the AuthName and AuthPassword keys in the profile with empty strings.

The only problem now is that users without admin privileges are unable to click on the Authentication Settings button on the VPN config to enter their own credentials