iOS Wi-Fi still prompting to trust certificate after Config Prof Cert install

djrory
Contributor

Our iPads do not automatically join one of our Wi-Fi networks because they require the user to select the Wi-Fi and then trust the cert. They are initially setup at Head Office then are sent to a store. But they do not join the Store Wi-Fi automatically on arrival, the user has to go to Wi-Fi settings, click on the SSID under "My networks" then press trust on the certificate.

We have a self-signed root, an intermediate and a Wi-Fi cert. All of which I have pulled directly from ClearPass our Wi-Fi authentication application.

I have put all of these certs into a Config Profile and pushed to the iPads, I have tried in separate profiles and also in the Wi-Fi payload profile but none of these work.

Does anyone have an idea what I am doing wrong here?

3947f4f115b44b45ab2b0578ea9d5593

00fa2681a75f46d5bcb0c2f00fb1838f

037044c7c14d49778d49edf64ed5dbcd

8651e81bb1674c2d9755d3223566dea5

3 REPLIES 3

JosephRecendez
New Contributor II

@djrory Did you ever figure this out? I am also seeing something similar. I am pushing out WiFi through SCEP and a WiFi payload. I am also being prompted to "Trust" a certificate from our DNS. The other odd thing is that after I accept the WiFi connects but the cert can not be found anywhere on the device.

Any insight would be appreciated.

djrory
Contributor

@JosephRecendez Unfortunately not, still struggling with this. I am pushing the CAs, intermediate and WiFi certs via a config profile, they all appear as trusted but no matter what the iPads still prompt to trust the cert when first connecting to our corporate wifi even though it already has the EXACT same cert and all certs in the chain of trust.

I've basically given up on this now, resigned to the fact that we will have to manually setup and trust the wifi on every device... kind of defeats the idea of MDM...

djrory
Contributor

I tried messing around with these settings but regardless of the configuration and trust settings it still prompts every time...
ec4a0ab7b51d4e8aa6fdcad3933be8b9