Issues downloading and updating apps - iOS 9.2.1

New Contributor III

I have a WHOLE bunch of iPads that are causing enough havoc with Apple servers that Apple has throttled our IP address for downloads.
I am using the latest version of Casper (9.8.2) and I'm seeing this on devices that have 9.2.1 on them.
These are the errors I'm seeing in the JSS logs:

Error assigning license to device: DLXM........., ErrorNumber: 9616, ErrorMessage: License already assigned Error managing licenses. ErrorNumber: 0 , ErrorMessage:null Error managing licenses. ErrorNumber: 9632 , ErrorMessage:Too many recent calls to manage licenses with identical requests Error revoking license from device: DMPH........., ErrorNumber: 9602, ErrorMessage: No license to disassociate.

I don't see ANY apps that would be causing an issue that are license based. I have all the correct ports open.
I have a support request filed with JAMF and I've also notified our state Apple Engineer. So I thought I would ask the gurus here to see if you had any ideas.



One of my costumers reported exactly the the same issue.
He told me when he changed the public IP it worked fine for one or two days and then Apple throttled this IP too. Apple denies this but recommended the Asset Cache server of the Apple server app to use to solve this issue.
Maybe someone at Apple needs to whitelist the IP addresses.

New Contributor

Hi @natesimons and @gda

Can you provide any further information on this as I am seeing this also and don't see anything in particular that is causing it.



New Contributor

I am having the same issues. Worked with Jamf support to clear my VPP errors and multiple requests to the APNs. However VPP and anything APNs related still takes an extremely long time, usually hours. The only thing I can think of now is Apple throttling the bandwidth of APNs requests. Does anyone know how to go about this? Any info will be greatly appreciated. Thanks!

New Contributor III

Interested in following this as we see the issue crop up from time to time as well.