Jamf Admin - Failing to upload pkgs.

sirsir
Contributor

Good Afternoon,

I've opened a support case with JAMF but haven't heard anything so I thought I'd try here until I do.

We're running JAMF 10.35.x and are unable to upload any pkgs to the cloud with JAMF Admin. The error is as follows:

 

There was a problem uploading the package to Jamf Cloud. Connection failure: "The operation couldn't be completed. ( error 504.)

This happens with any pkg file at any size. 

 

 

11 REPLIES 11

cbrewer
Valued Contributor II

You're probably running into PI-010453. Try Jamf Admin app version 10.34.

sirsir
Contributor

Unfortunately using 10.34.x doesn't seem to work either. 😑

mm2270
Legendary Contributor II

Maybe I'm missing something, but is there a specific reason you're using Jamf Admin.app to upload into Jamf Cloud? I've always just used the web upload function within the console to do that myself. Have you tried doing it that way yet to see if there's any difference?

scottb
Honored Contributor

Agree - at least if you're in Jamf Cloud...haven't used Admin in years as the web interface works 98% of the time.  Most of the fails we might see these days are when someone packages something really large, and a couple of tries usually does it. ¯\_(ツ)_/¯ 

lparnell
New Contributor II

I noticed this issue today as well. I was using Jamf Admin 10.33. Then I tried 10.35. Both had issues. To get around this I had to just do the package uploads through Jamf directly. This actually seems way easier, but I do wonder why Jamf Admin isn't working.

JKingsnorth
Contributor

Having the same issues. Went all the way back to 10.31 and still have issues. Its also not saving category changes and will not reflect deletion of packages in Computer Management > Packages. I also cannot delete packages from Jamf Pro that were already deleted from Jamf Admin, the page just loads blank.

afej
New Contributor II

Did you ever get an answer from JAMF?  I am having the same issue am playing email volley with tier 1

afej
New Contributor II

Up and running with 10.34.2

vogel
New Contributor

I'm also having trouble - trying to index packages and although it looks successful in Jamf Admin, changes are not reflected in Jamf Cloud. Category changes are also not working. Was running 10.32, updated to 10.37 today but will try with 10.34 if I can.

JminD
New Contributor II

Wanted to comment to keep this thread alive. I've also have been struggling with uploading a larger pkg through Jamf Admin (Ver 10.34.1) and the package initially completes the upload. But when I log out and log back into admin it shows that the package is highlighted red and the package is missing its file. 

Really crushing my work flow right now.

For those who may be curious. I don't upload through the cloud agent because anything pkg over 8gb doesn't play nice through the cloud agent. Doing it through Jamf admin usually works better...barely....but lately it's been 100% failure. I've uploaded this pkg over 20 times over the last two weeks now. It's getting to a point where I'm about to give up and go to erase-install for OS updates (which I don't want to do).

pbileci
New Contributor III

I just started getting this while trying to upload the latest version of Google Drive through Jamf Admin. I've always used Jamf Admin, even when we moved to the cloud and I haven't had any issues uploading packages. I was able to upload another package but the Google Drive package just won't upload.