Jamf And Intune integration

New Contributor II


We recently followed the guidelines to integrate JAMF and Intune.
It’s working fine, we are now able to apply conditional access policies that require MAC to be compliant.

But the user experience on the register process is a pain, to many inputs needed;
1- Azure/ADFS Sign in. To setup the company portal and register the MAC.
2- Second Azure Sign in (Myapps portal popup) – no password required, just email. (SSO doing its work here it seems)
3- Popup asking for JAMF/user credentials (Self Service icon displayed here).
4- Popup asking to accept publisher “JAMF Native MacOS connector”, or cancel.
5- Popup for key-chain password.

An example can be seen under this link. Not exactly the same experience, this one has less popups.

Is there a way to fine-tune and automate, as much as possible, the above procedure?

Thank you

Screenshots attached


Valued Contributor
Valued Contributor

Hmm very curious, this year we are going to introduce the intergration between our JSS and SCCM environment.
If you have any tips, pro-tips.

I am in!

Thijs - bol.com

New Contributor

Any update on this post ?

Contributor II

I'm just testing integration however having issues where the JSS isn't sending machine data to Intune...

New Contributor III

I am also having an issue with JAMF sending machine data to Intune. I see the mac in Azure but it never gets to Intune....

Valued Contributor
Valued Contributor

@simonep go to Azure AD -> MAM / MDM and add there Microsoft Intune and make sure your users are allowed to enroll

New Contributor II


We have just started configuring JAMF/Intune and we have this exact same issue.

The device registers with Azure but never shows in Intune. when we check the logs we see an error message.

(50097 - Device Authentication Required - DeviceId -DeviceAltSecId claims are null OR no device corresponding to the device identifier exists. )

Does anyone have any idea what this could mean?

thanks in advance

New Contributor III

Getting this same error, were you able to figure it out @MacLover ?

Contributor II

Yes this error also are on our side on some clients

The clients are registered in azure but still the error appear in the log

(50097 - Device Authentication Required - DeviceId -DeviceAltSecId claims are null OR no device corresponding to the device identifier exists. )

New Contributor II

@friveraLC we have managed to fix the issue by doing everything from scratch with the help of our support (jigsaw24) and they found that we were missing permissions on the Azure Jamf apps and also our Backend team only configured one of the Azure Jamf app. So it was caused by us missing few steps on the guide.

New Contributor II

@MacLover Can you be more clear on what it was you found and subsequently fixed? We were working just fine for over a week and then came back from holiday and found some of us weren't able to get in with same error. Now two of the four of us can get in. I wouldn't think permissions is the issue since some devices are found as compliant, but looking for any help we may find!


+1 too many logins