Jamf cloud Actions button does not work.

Valued Contributor

I am working on new groups of Macs, and in order to get Apple Remote Desktop to work, I have to select the Smart group and the View the members, then I hit the Action Button, in there I send a remote command and tell them all to allow ARD access. However when I hit the Action button all I get is a twirling blue icon, and nothing happens.

Makes no difference if I switch to a different browser, or a different computer on a different network. 
Any Suggestions as to what is broken? or something I can fix? 


Valued Contributor

Quick test and all goes through and I see 'EnableRemoteDesktop' MDM command pending, then done.

Does it work on an individual device rather than Mass Action? 

Not used ARD in.. a long time, but back in the day I've always scripted ARD via kickstart (many many examples) this one is old, but gives you an idea.. https://themacadmin.com/2009/08/12/script-enable-remote-management-ard/

EDIT: ran Mass Action again.. and get the same issue.. spinning blue thing.. 

Individual devices only have the option to disable it not enable it, which suggests it is on, but it isnt.
For some weird reason even though I use the kickstart script, the Macs will not share their screen until I have sent an Enable Remote Desktop command from my Jamf server. I think this is an Apple thing, requiring the MDM to issue the command.
But the spinning blue thing is frustrating, because it tells you nothing.

Valued Contributor II

Just ran into this today. I couldn't remote into one of our Macs. I sent the Disable Remote Desktop command twice. Then sent an Enable Remote Desktop command. And it connected magically.

Valued Contributor

I opened a ticket, and they asked me to try it with 5 macs, and it worked, then I pushed it to more, at ten Macs it took a min to launch the page, and a bit longer with twenty.
Since then I have had no reply from them. But it is back working, maybe a little slow.