Jamf Pro 10.32.2 Release


Hi Jamf Nation,

Today we are making an update for Jamf Pro available to include fixes for the MDM commands table that caused some Jamf Pro server performance issues and prevented apps from updating. A cloud upgrade is scheduled for this weekend, see below for details. Please check your Jamf Nation alerts or the release notes for additional details on this release.

Standard Cloud customers will be upgraded directly to 10.32.2 during this weekend’s scheduled release.

Read the full release notes here.

Thanks, Kaylee


Cloud Upgrade Schedule
Your Jamf Pro server, including any free sandbox environments, will be updated to Jamf Pro 10.32.2 based on your hosted data region below. Need assistance identifying the Hosted Data Region of your Jamf Cloud instance? Check out this guide to find out how.


Hosted RegionBeginsEnds
ap-southeast-2Sept 24 at 1400 UTCSept 24 at 2300 UTC
ap-northeast-1Sept 24 at 1500 UTCSept 24 at 2300 UTC
eu-central-1Sept 24 at 2200 UTCSept 25 at 0800 UTC
eu-west-2Sept 24 at 2300 UTCSept 25 at 0500 UTC
us-east-1Sept 25 at 0400 UTCSept 25 at 1900 UTC
us-east-1 sandboxSept 25 at 0000 UTCSept 25 at 0900 UTC
us-west-2Sept 25 at 0700 UTCSept 25 at 2000 UTC


Next Steps

For real-time messages about your upgrade, subscribe to alerts.

For information on what's new in Jamf Pro 10.32.2, please review the release notes


New Contributor III

I literally just updated to 10.32.1 yesterday.

Right! Seems like a lot of oops sorry we need to add one more thing to our product recently... Dont get me wrong I love that jamf is releasing patches, but a little more time could be spent testing pre-production?

New Contributor II

Me too! An update a day keeps the boredom away. 🙄

New Contributor III

I literally just updated and just kept the update train going.

Yup--me too!

Yep, same thing here as well...we've just gone through the process of change control, upgrading Staging and then Production only to wake up and see that there's a new patch 😅

Contributor III

Again?!?! Do you realize how much prep-work and paperwork each update and service outage entails for your larger customers with change control and internal communication requirements?!? 

Please step up your QA game!

New Contributor

What happened to inventory preload? Where did it go? 

Valued Contributor

Did someone remove all Q and A keys from the keyboards at Jamf?

New Contributor III

Sure seems to be a lot of "Hot Fix's" this time around. It really doesn't make the product look good! 

Valued Contributor

Would the issue around these tables explain why I can't distribute Mac App Store apps via the Self-Service any more? "Pending - All licenses are in use or the license is not assigned yet" - and no, the licenses are not in use...

New Contributor II

mschroder: Check if you have any computers or mobile devices with blank serial number in Jamf Pro - Search Inventory. If so, that could be the cause. It was in our case.

I logged in simply to say "thank you". After getting no quick help from Jamf Support on this urgent issue, your "fix" seems to be working right now. I found one single device with no SN and deleted the device record. Early reports are looking good that this may have started resolving our pending app installs and the VPP logs look clean since the device record was deleted.

Now I'm waiting for Jamf's after-action/post-mortem as to how one singular device (in a fleet of 12,000+) can effectively break our entire instance. Can't wait to hear what they have to say about THAT.

New Contributor II

Thank you, this ended up being the problem in our instance. Somehow an iPhone got enrolled without a serial number and all VPP license assignments ceased. I'm a new Jamf admin and was wracking my brain thinking I configured something wrong. Somewhat disconcerting that something so trivial can break a core functionality of the MDM.

Valued Contributor

Thanks for the hint. I have removed some devices with a blank serial number. That revived some searches (in fact I had to do the search for these devices directly in the DB, it did not conclude via the MDM), but it did not solve my app installation issue..

Valued Contributor

I'm curious to hear what you saw in your VPP logs (JAMFSoftwareServerVPP.log or something else?) before that cleanup. And yes, having the whole system break by a few entries without SN is quite strange. I better stop here before getting started on the many java tracebacks triggered by conditions that appears normal and harmless to me...

If this was in response to my reply above: the error that seemed to go away after we deleted the device record with the missing SN was error "9603". No more of those errors popped up in the VPP log after I deleted that device record. Can't say definitely that was the error that was causing our app install issues, but, like I said...that's the one that stopped appearing once the record was deleted. We were still seeing plenty of "9600" errors, but those didn't seem to affect the ability for apps to install.

New Contributor II

I'm surprised a fix for the long "Change Management" step at start-up wasn't worked into this release.


Hi all - from the Jamf Product team:

Thank you all for your feedback. Releasing two Jamf Pro updates back-to-back like this is definitely outside the norm. These particular releases are important but distinct, addressing a security vulnerability [PI-010111] and significant performance issues [PI-010150], [PI-010151]. Unfortunately, our path to resolve these issues as quickly as possible necessitated this unusual release cadence, and we regret the inconvenience this has caused.

I appreciate everyone who shared their thoughts in this thread; we hear you and we remain focused on improving the way we build and release great products in the future.

Valued Contributor II

Thanks for releasing this as a hot fix and not making us wait for 10.33.0. No bugs would be great, but when they do happen, I appreciate the option to patch them quickly.

Honored Contributor

It's Monday 9/27/2021 6:55am EDT and our jamfcloud server is unavailable. Still being updated?


Hi @kaylee_carlson, could you/your documentation team update the Linux system requirements for Jamf Pro 10.32.0/2 to reflect the 150GB of minimum freespace, at least when using jamfproinstaller.run?

This is the first time I've encountered this limit, which stopped the jamfproinstaller.run script outright. We run clustered with Linux instances in our AWS VPC with MySQL running separately on RDS. We're used to seeing the alert about MySQL not running (during install-time on the webapps), but those alerts do not stop the jamfproinstaller.run from running. In this case, the freespace limit (we use 20GB on each webapp instance) stopped the installer outright.

Hi @seabash, thank you for sharing this feedback. "Disk Space Check Added to Jamf Pro Installer for Linux" was documented in the Jamf Pro 10.31.0 Release Notes. Note that 150 GB is a recommendation, not a requirement.

Please let us know if you have other questions. Thanks!

Thanks for the info! Weird that info doesn't persist in subsequent releases. I don't _always_ scan all past release notes before installing later versions. Seems like it should be mentioned in system requirements?

I'll be adding the the `-d` flag per this note in 10.31.0 release notes which @PCalomeni mentioned.

You can bypass the disk space check by executing the installer with the -d flag. Execute a command similar to the following to skip the disk space check:

BTW without specifying anything, this is what I saw last night...


New Contributor II

@seabashWe run our Jamf on RHEL and were able to power past this message. I don't remember the exact language of the warning but I think it gives you a choice and you can continue despite the amount of available disk space. Worth trying! 

Valued Contributor

Unfortunately the '-d' only avoids that the script aborts due to the disk space. It does not prevent you from getting the warning and being asked to confirm that you want to continue 😞

So to run the install from a script without user interaction you will have to do some extra hacking to reply to the question...

You can add `-y` to the mix and bypass the disk space check and confirmations, and installs go smoothly. I learned this in my test environment and it worked a treat during my production upgrade last night.


sudo sh /path/on/linux/jamfproinstaller.run -- -d -y


Valued Contributor

Hi @seabash , thanks a lot for that hint. We had used the '-- -y' before, but I had not found a way to add the '-d' into the mix...